View Issue Details

IDProjectCategoryView StatusLast Update
0026838mantisbtbugtrackerpublic2020-05-03 04:34
ReporterFreddyJ Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.24.1Fixed in Version2.24.1 
Summary0026838: OS build field not filled in viewing mode
Description

"OS build" field is not filled in viewing mode. in update mode it is OK

Steps To Reproduce

Report a new issue with a value in the field "OS buid" and then click on the issue.

Additional Information

I think the problem is in the "bug_view_inc.php" file .

at line 450 : echo '<td class="bug-os-version">', string_display_line( $t_issue['os_version'] ), '</td>';

It should be : echo '<td class="bug-os-version">', string_display_line( $t_issue['os_build'] ), '</td>';

TagsNo tags attached.

Relationships

related to 0025902 closedvboctor Implement IssueViewPageCommand to separate logic from rendering of issue view page 
related to 0026840 resolvedatrol Non existing field name os_version used where os_build should be used 
related to 0026921 closedatrol View Issue page does not show "Product Build" (wrong key names in code) 

Activities

atrol

atrol

2020-04-01 14:27

developer   ~0063811

Last edited: 2020-04-01 15:01

View 2 revisions

Regression introduced in 2.23.0

While checking this, I found that there are some more places where os_version is used instead of os_build since many years.
Opened 0026840 for that.

atrol

atrol

2020-04-01 15:20

developer   ~0063812

PR https://github.com/mantisbt/mantisbt/pull/1643

polzin

polzin

2020-04-28 04:30

reporter   ~0063921

@atrol Is this really the correct way to fix it? From my limited understanding there are internal variable names (like os_build) and variable names that are used in configuration files (which are close to the user interface, so that someone configuring mantis only needs to know the GUI names, but not the internal names). I don't know what side effects changing names has for example for existing filters.

I think, it would be more consistant to change only bug_view_inc.php $t_issue['os_version'] --> $t_issue['os_build'], but leave config_defaults.php and IssueCommand as they are, as config files should use the GUI names.

There are a number of other cases, where the $t_issue-name does not match the config field names. This is not nice, but at least, it would be consistant.

polzin

polzin

2020-04-28 04:37

reporter   ~0063924

Related: 0026921

Related Changesets

MantisBT: master-2.24 76fa47a8

2020-04-01 14:45:28

atrol

Details Diff
Fix regression no display of OS Version field on View Issue Details page

Fixes 0026838
Affected Issues
0026838
mod - bug_view_inc.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/commands/IssueViewPageCommand.php Diff File

Issue History

Date Modified Username Field Change
2020-04-01 10:13 FreddyJ New Issue
2020-04-01 14:27 atrol Product Version 2.24.0 => 2.23.0
2020-04-01 14:27 atrol Note Added: 0063811
2020-04-01 14:28 atrol Assigned To => atrol
2020-04-01 14:28 atrol Status new => assigned
2020-04-01 14:33 atrol Relationship added related to 0025902
2020-04-01 14:34 atrol Target Version => 2.24.1
2020-04-01 15:00 atrol Relationship added related to 0026840
2020-04-01 15:01 atrol Note Edited: 0063811 View Revisions
2020-04-01 15:20 atrol Note Added: 0063812
2020-04-03 01:59 atrol Changeset attached => MantisBT master-2.24 76fa47a8
2020-04-03 01:59 atrol Status assigned => resolved
2020-04-03 01:59 atrol Resolution open => fixed
2020-04-03 01:59 atrol Fixed in Version => 2.24.1
2020-04-28 04:30 polzin Note Added: 0063921
2020-04-28 04:37 polzin Note Added: 0063924
2020-04-29 15:00 atrol Relationship added related to 0026921
2020-05-03 04:34 vboctor Status resolved => closed