View Issue Details

IDProjectCategoryView StatusLast Update
0023992mantisbtuipublic2018-06-13 04:16
Reporterr.zobelAssigned Tosyncguru 
PrioritynormalSeveritytweakReproducibilityalways
Status assignedResolutionopen 
Product Version2.11.1 
Target VersionFixed in Version 
Summary0023992: Font = Times News Roman after Upgrade from v2.7.0
Description

as the summary says, after upgrading the browser doesn't use the Open-Sans Font anymore :(

Steps To Reproduce

upgrade from v2.7 -> v2.11.1

TagsNo tags attached.

Relationships

related to 0023758 closedsyncguru Allow users to select font family that fits them best 
has duplicate 0024157 closedatrol Default font has changed after upgrade to Mantis 2.12 
related to 0023978 new Fonts are not rendered correctly in Windows clients 
related to 0024520 new Missing fallback for "Open Sans" font 

Activities

r.zobel

r.zobel

2018-02-16 10:37

reporter   ~0058907

after renaming the css\fonts.css to fonts.css.bak and using the open-sans.css from v2.7 as fonts.css, it works again.

r.zobel

r.zobel

2018-02-16 10:47

reporter   ~0058908

damn
after adding .woff2 to iis mime-types it works also with the new fonts.css

I followed these instructions
http://www.dirigodev.com/blog/web-development/404-errors-in-iis7-for-embedded-woff-font-files/

but I'am using the mime settings:
.woff2
font/x-woff

maybe, this should be added to the (update) instructions

syncguru

syncguru

2018-02-26 18:58

developer   ~0059044

@r.zobel I am confused ... Times News Roman is not a font family we support in MantisBT.

atrol

atrol

2018-02-27 01:57

developer   ~0059046

Times News Roman is not a font family we support in MantisBT.

I assume this was the default font of the browser as our font could not be loaded.
Easy to reproduce by setting $g_font_family = 'Non Existing';

atrol

atrol

2018-02-27 02:15

developer   ~0059047

We used .woff in older versions, but .woff2 since 0023758 (2.11.0)

This explains the issue https://stackoverflow.com/questions/25796609/font-face-isnt-working-in-iis-8-0

r.zobel

r.zobel

2018-03-05 06:42

reporter   ~0059082

Yes atrol, you are right. With »Times News Roman« I mean the browser default font.

r.zobel

r.zobel

2018-03-05 07:05

reporter   ~0059084

Last edited: 2018-03-05 10:40

View 2 revisions

Sorry for the title. Maybe you can change it to »(WOFF2) Fonts aren't rendered properly«
My ticket is a duplicate of 0023950

See Screenshot for a fix for Windows IIS.
»font/x-woff2« as MIME-Type also worked for me. But I changed it to »font/woff2« as discussed here: Related to this: https://stackoverflow.com/questions/28235550/proper-mime-type-for-woff2-fonts/28251873#28251873



IIS-MIME-TYPE.png (21,453 bytes)
IIS-MIME-TYPE.png (21,453 bytes)
dregad

dregad

2018-03-05 10:43

developer   ~0059089

My ticket is a duplicate of 0023950

Since 0023950 is itself a duplicate of 0023978, maybe this should be closed as duplicate as well ?

r.zobel

r.zobel

2018-03-05 11:01

reporter   ~0059090

0023978 is not the same. 0023978 can solved by changes in config_inc.php.

raymondf

raymondf

2018-03-23 11:02

reporter   ~0059294

Perhaps some additional information th help.
Our company still uses IE11 and MantisBT is running behind a firewall for security reasons.
I wanted to upgrade from 2.10 to 2.12 and encountered the same problem: the default font of IE11 instead of these new fonts.
I found out that IE11 doesn't support woff2. See this article: https://medium.com/minitheory-design/font-support-on-internet-explorer-woff-v-s-woff-2-0-961e20c88d1d
I think,, the option to rename open-sans.css works for me. And it explaines why I have no troubles with your Mantis and IE11, because you're using $g_cdn_enabled = ON.

atrol

atrol

2018-04-01 11:24

developer   ~0059393

@syncguru I think it's too early to desupport IE11, so I think it would be good if you could fix this regression.

dynasoft

dynasoft

2018-06-12 10:58

reporter   ~0060070

same problem with IE after upgrade to 2.15. Is there a short fix for me in the meantime till this gets patched? We are hosting mantis on an external Hoster, so no IIS Settings that i can change myself.
thanks a lot

atrol

atrol

2018-06-12 13:46

developer   ~0060073

same problem with IE after upgrade to 2.15.

Do you get the same when using Chrome or Firefox?
If yes, we are talking about the IIS configuration issue (missing mime type for .woff2)
If no, we are talking about the issue that IE11 is not able to render .woff2 fonts.

Until there is a fix, there is a workaround (some people call it fix) for both issues:
Add the following line to file config_inc.php

$g_cdn_enabled = ON;

Keep in mind that enabling CDN

  • can improve performance if your users are not accessing your Mantis instance from your intranet
  • can decrease performance if your users are accessing your Mantis instance in intranet
  • might decrease your system availability as it will not work if CDN is not available
  • decreases security as there are some more possibilities for MITM attacks
  • decreases privacy as the CDN providers might track users
mahindra

mahindra

2018-06-12 14:28

reporter   ~0060074

Last edited: 2018-06-12 14:30

View 2 revisions

$g_cdn_enabled = OFF; in Microsoft Edge Win10
Screenshot

we set $g_cdn_enabled = ON until this is done, because in our company we are using IE 11



Microsoft Edge Win10.png (101,054 bytes)
Microsoft Edge Win10.png (101,054 bytes)
dynasoft

dynasoft

2018-06-13 01:24

reporter   ~0060075

Hi atrol
No, it's only with IE, no problems with Chrome/Firefox.

$g_cdn_enabled = ON;
This helped, but i would rather disable this. A decrease in security and privacy is not what we want for our users. Is there a saver solution?

Thanks a lot

atrol

atrol

2018-06-13 01:58

developer   ~0060076

A decrease in security and privacy is not what we want for our users

You are talking about security but you are using IE? There are good reasons why Microsoft pushes Edge instead of IE. Security is one of them.

Is there a saver solution?

You could tweak source code and revert the changes from 0023758 that introduced the regression.

dynasoft

dynasoft

2018-06-13 02:19

reporter   ~0060079

Who says we use IE? We just want to support a good look on IE, because I bet some of our customers are still using it!
But I rather let the few IE's be ugly than weaken it for everyone. Maybe I'll look into the source code. Thanks for your help

raymondf

raymondf

2018-06-13 03:20

reporter   ~0060080

If IE11 is the cause of the problem and you want $g_cdn_enabled = OFF, you can do the following as workaround.
Use the old open-sans.css and rename it to fonts.css. To make it easier, I attach it. :)

The only (little) problem you then have, is that a user cannot change their own preferred font.



fonts.css (1,175 bytes)
atrol

atrol

2018-06-13 03:31

developer   ~0060081

you can do the following as workaround. ...

You missed at least one step: You have to copy the old .woff fonts to the fonts directory.

raymondf

raymondf

2018-06-13 04:01

reporter   ~0060082

Sorry, correct. It was already a couple of month ago that I did it :)
To be complete: the 2 font files as attachments.



DXI1ORHCpsQm3Vp6mXoaTXhCUOGz7vYGh680lGh-uXM.woff (22,656 bytes)
cJZKeOuBrn4kERxqtaUH3T8E0i7KZn-EPnyo3HZu7kw.woff (21,956 bytes)
dynasoft

dynasoft

2018-06-13 04:16

reporter   ~0060084

raymondf, a big thanks to you sir! I seem to come from an older Version and did not find this woff files. Perfect that you attached them!
I switched cdn back off and installed your files and the older fonts.css. After resetting the IE-cache it's running on Open Sans too.
Thanks alot you two. Great to get this awesome help!

Issue History

Date Modified Username Field Change
2018-02-16 10:32 r.zobel New Issue
2018-02-16 10:37 r.zobel Note Added: 0058907
2018-02-16 10:47 r.zobel Note Added: 0058908
2018-02-18 06:41 atrol Relationship added related to 0023758
2018-02-18 06:45 atrol Relationship added related to 0023978
2018-02-26 18:58 syncguru Note Added: 0059044
2018-02-27 01:57 atrol Note Added: 0059046
2018-02-27 02:15 atrol Note Added: 0059047
2018-03-05 06:42 r.zobel Note Added: 0059082
2018-03-05 07:05 r.zobel File Added: IIS-MIME-TYPE.png
2018-03-05 07:05 r.zobel Note Added: 0059084
2018-03-05 10:40 dregad Note Edited: 0059084 View Revisions
2018-03-05 10:43 dregad Note Added: 0059089
2018-03-05 11:01 r.zobel Note Added: 0059090
2018-03-05 12:26 vboctor Category webpage => ui
2018-03-06 00:27 vboctor Assigned To => syncguru
2018-03-06 00:27 vboctor Status new => assigned
2018-03-23 11:02 raymondf Note Added: 0059294
2018-03-23 15:10 atrol Relationship added has duplicate 0024157
2018-04-01 11:24 atrol Note Added: 0059393
2018-06-04 02:07 atrol Relationship added related to 0024520
2018-06-12 10:58 dynasoft Note Added: 0060070
2018-06-12 13:46 atrol Note Added: 0060073
2018-06-12 14:28 mahindra File Added: Microsoft Edge Win10.png
2018-06-12 14:28 mahindra Note Added: 0060074
2018-06-12 14:30 mahindra Note Edited: 0060074 View Revisions
2018-06-13 01:24 dynasoft Note Added: 0060075
2018-06-13 01:58 atrol Note Added: 0060076
2018-06-13 02:19 dynasoft Note Added: 0060079
2018-06-13 03:20 raymondf File Added: fonts.css
2018-06-13 03:20 raymondf Note Added: 0060080
2018-06-13 03:31 atrol Note Added: 0060081
2018-06-13 04:01 raymondf File Added: DXI1ORHCpsQm3Vp6mXoaTXhCUOGz7vYGh680lGh-uXM.woff
2018-06-13 04:01 raymondf File Added: cJZKeOuBrn4kERxqtaUH3T8E0i7KZn-EPnyo3HZu7kw.woff
2018-06-13 04:01 raymondf Note Added: 0060082
2018-06-13 04:16 dynasoft Note Added: 0060084