View Issue Details

IDProjectCategoryView StatusLast Update
0022555mantisbtfilterspublic2017-04-01 00:13
ReportervboctorAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0022555: Regression in custom field sorting
Description

Due some recent change, the custom field sorting doesn't work in some cases. By doesn't work I mean that clicking on the custom field header on View Issues page has no effect. This didn't always happen, but after some investigations, I figured out that this happens in the case where a custom field is name "Some custom field" but references in View Issues columns list (from manage columns) as 'some custom field' (different case). The logic that shows the field is case insensitive, but the logic for sorting by the field is case sensitive.

If the custom field name in the Manage Columns configure is changed to use the correct case, the sorting works again.

Could this be introduced by 0017367 ?

TagsNo tags attached.

Relationships

related to 0022392 closedcproensa Sorting all bugs list using a column header after applying a filter resets the filter 
related to 0022325 closedcproensa Sort by custom field in View issues page - doesn't work - or you will get an error in "filters" 

Activities

atrol

atrol

2017-03-21 03:51

developer   ~0056137

Seems to be the issue which is mentioned at 0022392:0055731

cproensa

cproensa

2017-03-21 18:59

developer   ~0056149

I have provided a fix in 0022392
which certainly looks like your issue described, since setting sort order from column headers was resetting custom field filtering.

however, i don't think it has to do with case sensitiveness... that may be another issue?

vboctor

vboctor

2017-03-21 19:01

manager   ~0056150

@cproensa I'm pretty sure there is a case sensitivity issue since I was able to reproduce it, can you please test before / after your fix, so see if this issue is also fixed.

cproensa

cproensa

2017-03-21 19:51

developer   ~0056151

there is a case sensitivity issue

right, this issue is different than 0022392

I think that a proper fix would be to use custom field numeric ids in the parameters name for sorting and filter forms fields, instead of names.

vboctor

vboctor

2017-03-21 21:55

manager   ~0056154

Sounds good as long it doesn't break filters serialized in cookies or saved to db.

cproensa

cproensa

2017-03-22 21:09

developer   ~0056167

@vboctor try this PR: https://github.com/mantisbt/mantisbt/pull/1064

The approach is: when loading the columns from configuration, sanitize those referencing custom fields so that the actual cf names are used in runtime

Related Changesets

MantisBT: master-2.2 c612d8da

2017-03-22 20:45:46

cproensa


Committer: vboctor Details Diff
Fix lowercase custom field column names

Fix column names for custom field columns that may be stored as
lowercase in configuration. See issue 0017367
If the system was working fine with lowercase names, then database is
case-insensitive, eg: mysql.
Fix by forcing a search with current name to get the id, then get the
actual name by looking up this id.

Fixes: 0022555
mod - core/bug_api.php Diff File
mod - core/columns_api.php Diff File
mod - core/helper_api.php Diff File

Issue History

Date Modified Username Field Change
2017-03-21 03:32 vboctor New Issue
2017-03-21 03:32 vboctor Status new => assigned
2017-03-21 03:32 vboctor Assigned To => cproensa
2017-03-21 03:50 atrol Relationship added related to 0022392
2017-03-21 03:51 atrol Note Added: 0056137
2017-03-21 18:59 cproensa Note Added: 0056149
2017-03-21 19:01 vboctor Note Added: 0056150
2017-03-21 19:51 cproensa Note Added: 0056151
2017-03-21 21:55 vboctor Note Added: 0056154
2017-03-22 21:09 cproensa Note Added: 0056167
2017-03-22 22:25 vboctor Changeset attached => MantisBT master-2.2 c612d8da
2017-03-22 22:25 cproensa Status assigned => resolved
2017-03-22 22:25 cproensa Resolution open => fixed
2017-03-22 22:25 cproensa Fixed in Version => 2.2.3
2017-03-22 23:18 vboctor Target Version 2.3.0 => 2.2.3
2017-03-27 17:00 cproensa Relationship added related to 0022325
2017-04-01 00:13 vboctoradmin Status resolved => closed