View Issue Details

IDProjectCategoryView StatusLast Update
0022100mantisbtcode cleanuppublic2019-03-16 20:20
Reportervboctor Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.20.0Fixed in Version2.20.0 
Summary0022100: Take care of released/obsolete flag when accessing version_cache_array_rows() cache
Description

It seems that an optimization was added to cache all versions before using them on pages like Changelog. The cache includes all versions independent of flags like obsolete or released. When accessing the cache, the code must filter as appropriate. See 0011604 for a bug that was introduced by this change. We should make sure other bugs were not introduced because of that.

TagsNo tags attached.

Relationships

related to 0024821 closedcproensa Wrong caching in version API 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 66a60cd2

2019-02-13 06:28:24

cproensa


Committer: vboctor Details Diff
Account for released version flag

Manage the released version flag in version_get_all_rows.

Fixes: 0022100
Affected Issues
0022100
mod - core/version_api.php Diff File

Issue History

Date Modified Username Field Change
2017-01-01 16:03 vboctor New Issue
2019-02-12 18:21 cproensa Relationship added related to 0024821
2019-02-14 05:46 cproensa Assigned To => cproensa
2019-02-14 05:46 cproensa Status new => assigned
2019-02-24 16:41 vboctor Changeset attached => MantisBT master 66a60cd2
2019-02-24 16:41 cproensa Status assigned => resolved
2019-02-24 16:41 cproensa Resolution open => fixed
2019-02-24 16:41 cproensa Fixed in Version => 2.20.0
2019-02-24 16:44 vboctor Target Version => 2.20.0
2019-03-16 20:20 vboctor Status resolved => closed