View Issue Details

IDProjectCategoryView StatusLast Update
0019825mantisbtfilterspublic2015-06-27 03:52
Reporterwkarl Assigned Toatrol  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.19 
Target VersionFixed in Version 
Summary0019825: view_all_bug_page: Filter of reporters not showiing reporters of subprojects
Description

On the "View Issues" page, view_all_bug_paghe.php, in the filters section at the top, the "Rep√ľorter" dropdown does not contain reporters that have reported issues on the subproject.

Steps To Reproduce

Create projects with subprojects, report issues in the subprojects, select the main project, goto "View Issues" and try to filter ba reporter: The reporters of issues in subprojects can not be selected.

Additional Information

I'm not sure if this is a dup of 0006105 but that issue seems to cover a problem with the "All projects" selection. As mentioned before, I do not select "All projects", but my main project.

Anyway, 0006105 seems to be open, acknowledged and unassigned since 2009-05-19. Do you intend to work on this?

TagsNo tags attached.

Relationships

duplicate of 0006105 acknowledged Filter "reporter", "monitored" and "assigned to" does not include Members of Subprojects 

Activities

atrol

atrol

2015-06-10 03:03

developer   ~0050884

It's a duplicate of 0006105, your case is described in summary (... does not include Members of Subprojects) and in additional information (... same problem exist when I structure the projects by means of a parent "empty" project)

Do you intend to work on this?
There is no developer assigned

Submitting a patch is always a good idea, as it increases the chances of improvement eventually making it into MantisBT core. All contributions are welcome and greatly appreciated.

Patch submissions can be made in several ways. In the order of preference:

  1. Send us a Pull Request on our Github repository [1]
  2. Attach a GIT patch to the issue
  3. Attach a Unified Diff, clearly specifying the patch's base release

Kindly avoid to upload entire modified PHP files.

Please make sure that your submissions adhere to our Coding Guidelines [2], if they don't your patch might be rejected.

[1] https://github.com/mantisbt/mantisbt
[2] http://www.mantisbt.org/wiki/doku.php/mantisbt:coding_guidelines

Issue History

Date Modified Username Field Change
2015-06-10 02:27 wkarl New Issue
2015-06-10 03:03 atrol Assigned To => atrol
2015-06-10 03:03 atrol Status new => resolved
2015-06-10 03:03 atrol Resolution open => duplicate
2015-06-10 03:03 atrol Note Added: 0050884
2015-06-10 03:03 atrol Relationship added duplicate of 0006105
2015-06-27 03:52 atrol Status resolved => closed