MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0014088mantisbtbugtrackerpublic2012-03-26 01:252013-10-18 16:51
Reportervboctor 
Assigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target Version1.3.xFixed in Version 
Summary0014088: Mantis 1.3.0 blocking issues
DescriptionThis is a parent issues for blockers for 1.3.0 release. The bar for issues to become children of this issue is that they should be regressions compared to 1.2.x.
TagsNo tags attached.
Attached Files

- Relationships
related to 0016444resolvedvboctor Remove nusoap from 1.3 release 
related to 0016446resolvedvboctor Merge MantisConnect configs into MantisBT standard configs 
parent of 0014087resolvedvboctor Installation script doesn't set the crypto_master_salt causing errors 
parent of 0014086resolveddregad Default administrator timezone to server timezone 
parent of 0014089resolvedvboctor "Operation Successful" notifications are not centered 
parent of 0014090resolvedvboctor Private are not rendered any differently than public notes 
parent of 0013691resolveddregad misspelled XHTML in admin/system_utils.php 
parent of 0014099resolveddregad Implement new message format for master branch at translatewiki 
parent of 0013304resolveddregad Error handler causes XML Parsing Errors 
parent of 0014119resolveddregad Use new MantisBT logo 
parent of 0014217resolvedvboctor PHP error when attempting to save a filter 
parent of 0014398resolveddregad Support for PostgreSQL broken in 1.3 
parent of 0014756resolveddregad Sub project always fails at "check_selected" method when calling print_subproject_option_list 
parent of 0014760closedgrangeway Bug Report Text Input Cannot Take Special Characters 
parent of 0014759resolveddregad Access Denied Page Has XML Parse Error 
parent of 0015446resolveddregad Using allowed html tags in text fields causes XML parse errors 
parent of 0015653resolveddregad APPLICATION ERROR 1303 when trying to reopen an issue 
parent of 0016020resolveddregad Port Fix of 0011684 to master branch 

-  Notes
User avatar (0031567)
atrol (developer)
2012-03-30 02:47
edited on: 2012-03-31 09:13

Regressions or not?
0011684:0027874
0012245

User avatar (0031585)
dhx (reporter)
2012-03-31 10:13

0011684 can probably be considered a regression in 1.3.x because it looks like (from lots of negative feedback on the change) the change will only be possible if we completely rewrite custom field functionality in MantisBT.

I don't consider 0012245 a regression in 1.3.x. This was a navigation element that required JavaScript to work without a fallback mechanism.
User avatar (0031586)
dregad (developer)
2012-04-01 09:39

Not sure if 0013304 really qualifies as "blocking" - but for sure it's annoying.
User avatar (0035034)
seyof (reporter)
2013-02-05 12:14

it's boring and annoying
User avatar (0036835)
cisco (reporter)
2013-05-12 22:35

done
User avatar (0038128)
grangeway (reporter)
2013-09-28 18:40

Removing sticky issue
User avatar (0038137)
rombert (developer)
2013-09-29 14:17

Reopening, not sure why Paul closed it...
User avatar (0038141)
vboctor (administrator)
2013-09-29 15:35

@dergad, it would be great if you can update the team on the progress to address issues identified with "master" and when do you expect to merge back into master. It would be great if everyone is aware of where we are at with this.
User avatar (0038188)
vboctor (administrator)
2013-10-03 13:18

I'm using "related to" to identify issues that would ideally be addressed, but are not required. These are lower priority than blocking, but higher priority that just issues with target version set to 1.3. We could switch to target version for these instead. Thoughts?
User avatar (0038190)
atrol (developer)
2013-10-03 14:46

Do we need an issue "Mantis 1.3.0 blocking issues"?
We can set target version to 1.3.x, set severity to "blocking" and store a filter for it.
User avatar (0038192)
vboctor (administrator)
2013-10-03 16:16

Works for me.
User avatar (0038229)
vboctor (administrator)
2013-10-09 00:12

I've created "Major v1.3 Issues" public filter which shows issues targeted to 1.3.x release, that are not resolved, that has severity of "major" or higher. We should triage the issues showing up there.

I'm closing this issue in favor of the above filter.

- Issue History
Date Modified Username Field Change
2012-03-26 01:25 vboctor New Issue
2012-03-26 01:25 vboctor Relationship added parent of 0014087
2012-03-26 01:26 vboctor Relationship added parent of 0014086
2012-03-26 01:26 vboctor Status new => confirmed
2012-03-26 01:26 vboctor Summary Mantis 1.3.0 blocking issue => Mantis 1.3.0 blocking issues
2012-03-26 01:26 vboctor Sticky Issue No => Yes
2012-03-26 01:34 vboctor Relationship added parent of 0014089
2012-03-26 01:46 vboctor Relationship added parent of 0014090
2012-03-26 04:06 atrol Relationship added parent of 0013691
2012-03-26 04:07 atrol Relationship added parent of 0012943
2012-03-26 15:14 atrol Relationship added parent of 0014099
2012-03-30 02:47 atrol Note Added: 0031567
2012-03-31 09:13 atrol Note Edited: 0031567 View Revisions
2012-03-31 10:13 dhx Note Added: 0031585
2012-04-01 09:39 dregad Note Added: 0031586
2012-04-01 09:40 dregad Relationship added parent of 0013304
2012-04-02 06:17 atrol Relationship added parent of 0014119
2012-04-25 11:18 dregad Relationship deleted parent of 0012943
2012-05-06 16:35 vboctor Relationship added parent of 0014217
2012-05-15 04:56 prashant2121 Note Added: 0031836
2012-05-15 05:18 dregad Note Deleted: 0031836
2012-06-20 07:49 dregad Relationship added parent of 0014398
2012-10-02 04:28 dregad Relationship added parent of 0014756
2012-10-03 04:04 dregad Relationship added related to 0014760
2012-10-03 04:06 dregad Relationship added related to 0014759
2012-10-03 04:07 dregad Relationship replaced parent of 0014759
2012-10-03 04:07 dregad Relationship replaced parent of 0014760
2013-01-30 16:06 atrol Relationship added parent of 0015446
2013-02-05 12:14 seyof Note Added: 0035034
2013-03-15 16:10 atrol Relationship added parent of 0015653
2013-05-12 22:35 cisco Note Added: 0036835
2013-06-06 06:39 atrol Relationship added parent of 0016020
2013-08-16 04:38 hero2289 Tag Attached: closed
2013-08-16 06:33 atrol Tag Detached: closed
2013-09-28 18:40 grangeway Note Added: 0038128
2013-09-28 18:40 grangeway Status confirmed => closed
2013-09-28 18:40 grangeway Resolution open => no change required
2013-09-29 14:17 rombert Note Added: 0038137
2013-09-29 14:17 rombert Status closed => confirmed
2013-09-29 15:35 vboctor Note Added: 0038141
2013-10-02 20:38 vboctor Relationship added related to 0016444
2013-10-03 13:14 vboctor Relationship added related to 0016446
2013-10-03 13:18 vboctor Note Added: 0038188
2013-10-03 14:46 atrol Note Added: 0038190
2013-10-03 16:16 vboctor Note Added: 0038192
2013-10-09 00:12 vboctor Note Added: 0038229
2013-10-09 00:12 vboctor Status confirmed => closed
2013-10-09 00:12 vboctor Assigned To => vboctor
2013-10-18 13:36 atroladmin Sticky Issue Yes => No


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.2009 seconds.
memory usage: 3,205 KB
Powered by Mantis Bugtracker