View Issue Details

IDProjectCategoryView StatusLast Update
0027994mantisbtadministrationpublic2021-03-07 18:28
Reporterjensberke Assigned Todregad  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.24.2 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027994: "Add Version" without entering a version number outputs "Operation successful" though no version has actually been added
Description

When you want to add a version number to a project, this number is obviously something that's required to add it. However, if you don't enter a version number and just click "Add Version" or "Add and Edit Version", Mantis reacts with the wrong message "Operation successful", as if a version has been added.

I suggest that Mantis

  • either makes the input field for the version number mandatory, disabling "Add Version" and "Add and Edit Version" as long as no value has been entered
  • or prints an error message when "Add Version" or "Add and Edit Version" are clicked with a blank input field
Steps To Reproduce
  1. Go to "Manage", click on "Manage Projects" and then on any project in the project list
  2. Leave the input field for the new version number next to the "Add Version" button blank
  3. Click on "Add Version" or "Add and Edit Version"
  4. The wrong message "Operation successful" will be output (on page manage_proj_ver_add.php), but no version has been added
TagsNo tags attached.

Activities

dregad

dregad

2021-03-01 12:06

developer   ~0065159

Issue is confirmed

dregad

dregad

2021-03-01 12:31

developer   ~0065160

PR https://github.com/mantisbt/mantisbt/pull/1744

jensberke

jensberke

2021-03-02 12:13

reporter   ~0065163

Thanks for responding and fixing it so fast.

On a side note: have there been problems regarding email notifications here recently? I have all email notifications enabled here, and there's no active spam filter on my mail server (I know that because it's self-hosted). But I didn't receive email notifications for the changes in this ticket. Also not for recent changes in 0022408, which I had reported a while ago and for which I definitely had received email notifications for earlier changes.

dregad

dregad

2021-03-03 06:10

developer   ~0065164

have there been problems regarding email notifications here recently?

I didn't pay attention to it until you mentioned it, but indeed there seems to be a problem.
I'll look into it, thanks for the heads up.

dregad

dregad

2021-03-06 18:50

developer   ~0065188

The problem with notifications should be fixed now.

jensberke

jensberke

2021-03-07 06:28

reporter   ~0065194

Yes, I received a notification email for your latest note, and the notification emails for the previous changes of this ticket have arrived now as well.

Related Changesets

MantisBT: master d1b99b56

2021-03-01 12:29:31

dregad

Details Diff
Version field is now required

When adding a new version from manage_proj_edit_page.php via the
'Add Version' or 'Add and Edit Version', it should not be allowed to
submit an empty field.

The HTML required attribute has been added to the 'version' input, and
the manage_proj_ver_add.php page displays an error message if no version
was created.

Fixes 0027994
Affected Issues
0027994
mod - manage_proj_edit_page.php Diff File
mod - manage_proj_ver_add.php Diff File

MantisBT: master 8da89e65

2021-03-02 02:50:31

dregad

Details Diff
Make Category field required too

To be consistent with the Version field, as suggested by @atrol.

Issue 0027994
Affected Issues
0027994
mod - manage_proj_edit_page.php Diff File