View Issue Details

IDProjectCategoryView StatusLast Update
0026150mantisbtbugtrackerpublic2020-01-07 03:37
Reporterdregad Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.23.0Fixed in Version2.23.0 
Summary0026150: Closing issues via group action with empty note creates a bugnote record
Description

This regression was initially reported by @syncguru in ~0062828, following @atrol's closing of several issues.

List of affected issues (from the 16.09.2019 update): 0007584, 0007642, 0020789, 0022822, 0025237, 0026105, 0026107, 0026111, #26112, 0026115. These were identified by looking at Timeline, a more thorough check should be performed against the database

Steps To Reproduce
  • Select an issue from View Issues page
  • Pick Close from the select at bottom of the issues list and click OK
  • On bug_actiongroup_page.php, leave Add Note field empty and click Close Issues button

Look at the closed issue and notice that a new, empty bugnote was created

Additional Information

According to git bisect, MantisBT master 13d0f15d is the first bad commit

TagsNo tags attached.

Relationships

related to 0009802 closedvboctor Support attachments associated with private notes 
related to 0026570 closedatrol Assigning bug from group action creates empty bugnote 

Activities

dregad

dregad

2019-09-17 07:11

developer   ~0062841

@vboctor this is caused by no longer aborting bugnote_add() if bugnote_text is empty [1]. I'm not sure why this change was necessary in the context of fixing 0009802 (Support private attachments with empty note) - from my perspective, private or not a bugnote should only be created if it has content.

atrol

atrol

2019-09-17 12:58

developer   ~0062856

Look at the closed issue and notice that a new, empty bugnote was created

Cleaned up the notes

dregad

dregad

2019-12-04 03:40

developer   ~0063187

Assigned to vboctor as discussed on Gitter

vboctor

vboctor

2019-12-06 02:13

manager   ~0063190

PR: https://github.com/mantisbt/mantisbt/pull/1586

Related Changesets

MantisBT: master 13d0f15d

2019-08-03 17:51:15

vboctor

Details Diff
Support private attachments with empty note Affected Issues
0009802, 0026150
mod - bugnote_add.php Diff File
mod - bugnote_view_inc.php Diff File
mod - core/bugnote_api.php Diff File

MantisBT: issue26150_blank_note_group_close 3eaf5cca

2019-12-06 02:11:18

vboctor

Details Diff
Avoid blank notes on group resolve/close actions

Fixes 0026150

Signed-off-by: Victor Boctor <victor@mantishub.net>
Affected Issues
0026150
mod - core/bug_api.php Diff File

MantisBT: master 89b5f4c5

2019-12-06 02:11:18

vboctor

Details Diff
Avoid blank notes on group resolve/close actions

Fixes 0026150

Signed-off-by: Victor Boctor <victor@mantishub.net>
Affected Issues
0026150
mod - core/bug_api.php Diff File

Issue History

Date Modified Username Field Change
2019-09-17 06:17 dregad New Issue
2019-09-17 06:18 dregad Changeset attached => MantisBT master 13d0f15d
2019-09-17 06:22 dregad Relationship added related to 0009802
2019-09-17 07:11 dregad Status new => confirmed
2019-09-17 07:11 dregad Note Added: 0062841
2019-09-17 12:58 atrol Note Added: 0062856
2019-12-04 03:40 dregad Assigned To => vboctor
2019-12-04 03:40 dregad Status confirmed => assigned
2019-12-04 03:40 dregad Note Added: 0063187
2019-12-06 02:11 vboctor Changeset attached => MantisBT issue26150_blank_note_group_close 3eaf5cca
2019-12-06 02:11 vboctor Status assigned => resolved
2019-12-06 02:11 vboctor Resolution open => fixed
2019-12-06 02:13 vboctor Note Added: 0063190
2019-12-06 02:25 vboctor Status resolved => assigned
2019-12-06 02:25 vboctor Resolution fixed => open
2019-12-09 03:05 vboctor Changeset attached => MantisBT master 89b5f4c5
2019-12-09 03:05 vboctor Status assigned => resolved
2019-12-09 03:05 vboctor Resolution open => fixed
2019-12-09 03:05 vboctor Fixed in Version => 2.23.0
2019-12-09 04:31 vboctor Status resolved => closed
2020-01-07 03:37 dregad Relationship added related to 0026570