View Issue Details

IDProjectCategoryView StatusLast Update
0025910mantisbtadministrationpublic2020-02-18 04:05
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.22.0 
Target Version2.22.0Fixed in Version2.22.0 
Summary0025910: Simplify displaying of complex values in adm_config_report page
Description

To reduce the size of adm_config_report page, we can avoid displaying complex values inlined in the result table. Those values usually are large arrays that take up lot of screen space, adding to the already big size of this report.
Instead, we can use use an on-demand displaying of the content through a rest api call.

TagsNo tags attached.

Relationships

related to 0026712 closeddregad Provide a way to 'show content' for all complex items on Manage Configuration Report page 
related to 0026110 closeddregad [Show content] for Complex Configuration option doesn't work when mod_rewrite is disabled 

Activities

Related Changesets

MantisBT: master 7924e4c8

2019-03-14 14:54:02

cproensa


Committer: dregad Details Diff
Don't show complex values in adm_config_report

To save page space, don't show complex values in adm_config_report page.
Use an on-demand retrieval of the content through a rest api call.
Affected Issues
0025910
mod - adm_config_report.php Diff File
mod - api/rest/restcore/internal_rest.php Diff File
mod - core/config_api.php Diff File
add - js/adm_config_report.js Diff File

MantisBT: master 437305f5

2019-03-19 20:41:31

cproensa


Committer: dregad Details Diff
Don't retrieve complex values for config report

Since complex values are not displayed, don't return the content value
from database to save time and memory.

Fixes: 0025910
Affected Issues
0025910
mod - adm_config_report.php Diff File

Issue History

Date Modified Username Field Change
2019-07-08 19:25 cproensa New Issue
2019-07-08 19:25 cproensa Status new => assigned
2019-07-08 19:25 cproensa Assigned To => cproensa
2019-07-08 19:31 cproensa Note Added: 0062370
2019-07-15 08:42 dregad Changeset attached => MantisBT master 437305f5
2019-07-15 08:42 cproensa Status assigned => resolved
2019-07-15 08:42 cproensa Resolution open => fixed
2019-07-15 08:42 cproensa Fixed in Version => 2.21.2
2019-07-15 10:32 dregad Fixed in Version 2.21.2 => 2.22.0
2019-07-15 10:32 dregad Target Version => 2.22.0
2019-08-25 12:36 vboctor Status resolved => closed
2020-02-17 16:59 atrol Relationship added related to 0026712
2020-02-18 03:21 dregad Relationship added related to 0026110
2020-02-18 04:05 dregad Changeset attached => MantisBT master 7924e4c8