View Issue Details

IDProjectCategoryView StatusLast Update
0025033mantisbtinstallationpublic2019-01-02 17:25
ReporterhannoAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.18.0 
Target Version2.19.0Fixed in Version2.19.0 
Summary0025033: Warning with PHP 7.3: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
Description

I'm seeing this warning in my logs if I try to use mantis with PHP 7.3:

PHP Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /[path]/core/install_helper_functions_api.php on line 467

Probably just a cosmetic issue, but should be fixed now that PHP 7.3 is stable.

TagsNo tags attached.

Activities

atrol

atrol

2018-12-07 09:26

developer   ~0061045

PR https://github.com/mantisbt/mantisbt/pull/1417

atrol

atrol

2018-12-07 09:29

developer   ~0061046

@hanno you wrote

if I try to use mantis with PHP 7.3

Am I right that you are not talking about using or installing a new MantisBT, but about upgrading an old version of MantisBT?

hanno

hanno

2018-12-07 09:32

reporter   ~0061047

I was upgrading from a previous (2.17.1) version today, so it's very well possible that the warning happened during the update.

atrol

atrol

2018-12-07 09:40

developer   ~0061048

I was upgrading from a previous (2.17.1) version today

Thanks for the feedback.

That's a bit strange, as there is no difference in database schema between 2.17.1 and 2.18.0, so I don't expect that the code in install_helper_functions_api.php on line 467 is executed.
Seems that loading/parsing the code is enough to throw the warning.

Related Changesets

MantisBT: master 3250e83b

2018-12-07 09:17:47

atrol

Details Diff
Fix PHP 7.3 warning

Starting from PHP 7.3, continue statements targeting switch control flow
structures generate a warning [1].

In our case, we don't want just to break the switch, but continue with
the next row of the database fetch.

Fixes 0025033

[1] http://php.net/manual/en/migration73.incompatible.php
Affected Issues
0025033
mod - core/install_helper_functions_api.php Diff File

Issue History

Date Modified Username Field Change
2018-12-07 08:45 hanno New Issue
2018-12-07 09:24 atrol Assigned To => atrol
2018-12-07 09:24 atrol Status new => assigned
2018-12-07 09:25 atrol Target Version => 2.19.0
2018-12-07 09:26 atrol Note Added: 0061045
2018-12-07 09:29 atrol Note Added: 0061046
2018-12-07 09:32 hanno Note Added: 0061047
2018-12-07 09:40 atrol Note Added: 0061048
2018-12-11 10:59 atrol Changeset attached => MantisBT master 3250e83b
2018-12-11 10:59 atrol Status assigned => resolved
2018-12-11 10:59 atrol Resolution open => fixed
2018-12-11 10:59 atrol Fixed in Version => 2.19.0
2019-01-02 17:25 vboctor Status resolved => closed