View Issue Details

IDProjectCategoryView StatusLast Update
0024741mantisbtplug-inspublic2018-10-16 23:41
ReporterfmanAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.18.0Fixed in Version2.18.0 
Summary0024741: Plugin Columns - Export CSV or Excel - PHP 7.2.7 - crash error 500 - Reason missing 2 argument in call
Description

It seems that PHP 7.2.7 is very rigid about calling a function will the wrong number of parameters, then

in this file/function
cvs_api.php / csv_format_plugin_column_value()

call to
$t_column_object->value( $p_bug);

needs to be changed to
$t_column_object->value( $p_bug, 0 ); ( 0 or 1000 is the same)

because in MantisColumn.class.php
<b>public function value( BugData $p_bug, $p_columns_target ) {</b>

hope I was not too much confusing :) .

regards

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master da36f79c

2018-09-08 05:50:30

dregad

Details Diff
Make 2nd param of MantisColumn::value() optional

In csv_api.php, the function csv_format_plugin_column_value() calls this
method with only one argument, causing an error on PHP 7.2.

Fixes 0024741
Affected Issues
0024741
mod - core/classes/MantisColumn.class.php Diff File

Issue History

Date Modified Username Field Change
2018-09-07 10:46 fman New Issue
2018-09-08 06:05 dregad Assigned To => dregad
2018-09-08 06:05 dregad Status new => assigned
2018-09-08 06:05 dregad Note Added: 0060623
2018-09-08 06:06 dregad Target Version => 2.18.0
2018-09-24 02:13 dregad Changeset attached => MantisBT master da36f79c
2018-09-24 02:13 dregad Status assigned => resolved
2018-09-24 02:13 dregad Resolution open => fixed
2018-09-24 02:13 dregad Fixed in Version => 2.18.0
2018-10-16 23:41 vboctor Status resolved => closed