View Issue Details

IDProjectCategoryView StatusLast Update
0024577mantisbtattachmentspublic2019-08-25 17:04
ReporterKyle_Katarn Assigned Tovboctor  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.15.0 
Target Version2.23.0Fixed in Version2.23.0 
Summary0024577: Deleting a note, should delete associated attachments
Description

When deleting a note made of 2 images (attachments) + text, delete operation has to be requested 3 times, not one

(each operation delete only 1 item, while I would have expected a 1 click operation)

TagsNo tags attached.

Relationships

related to 0021733 resolvedvboctor Attachments should be linkable to notes in db 

Activities

atrol

atrol

2018-07-07 16:53

developer   ~0060226

To explain the current behavior:

Attachments and notes are not linked (known feature request 0021733), they are just visually grouped, see 0021727.

If a user submits a note with an attachments within a specified number of seconds (default is 3) the attachment seems to be linked to the note.
This can be configured by setting $g_issue_activity_note_attachments_seconds_threshold = 3;

Kyle_Katarn

Kyle_Katarn

2018-07-14 08:42

reporter   ~0060268

I agree... this is confusing for end user

vboctor

vboctor

2019-07-22 01:44

manager   ~0062405

PR: https://github.com/mantisbt/mantisbt/pull/1529

Issue History

Date Modified Username Field Change
2018-07-01 05:36 Kyle_Katarn New Issue
2018-07-07 16:53 atrol Note Added: 0060226
2018-07-07 16:53 atrol Relationship added related to 0021733
2018-07-07 16:53 atrol Severity minor => feature
2018-07-14 08:42 Kyle_Katarn Note Added: 0060268
2019-07-22 01:31 vboctor Assigned To => vboctor
2019-07-22 01:31 vboctor Status new => assigned
2019-07-22 01:34 vboctor Category bugtracker => attachments
2019-07-22 01:44 vboctor Note Added: 0062405
2019-08-25 16:31 vboctor Status assigned => resolved
2019-08-25 16:31 vboctor Resolution open => fixed
2019-08-25 16:31 vboctor Fixed in Version => 2.23.0
2019-08-25 16:31 vboctor Target Version => 2.23.0
2019-08-25 17:04 vboctor Summary When deleting a note made of 2 images (attachments) + text, delete operation has to be requested 3 times, not one => Deleting a note, should delete associated attachments