View Issue Details

IDProjectCategoryView StatusLast Update
0023793mantisbtemailpublic2018-01-20 07:23
ReporterwangyouworldAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2.10.0 
Target VersionFixed in Version 
Summary0023793: APPLICATION ERROR #1201 It is not allowed to use disposable e-mail addresses.
Description

After upgrading to 2.10.0, I added a user, email address, such as: 12345678@qq.com

However, the addition failed, suggesting:

APPLICATION ERROR #1201

It is not allowed to use disposable e-mail addresses.

In the log, I found this message:

MAIL_VERBOSE email_api.php:137 email_is_valid() Validating address '12345678@qq.com' with method 'html5'

This is a valid e-mail address, do not know why this is so.

Like, 12345678@qq.com mail address, add this account on February 06, 2017 is successful.

Can not add after upgrading the new version.

Do I ignore some of the configuration?

thank you very much!

From google translate

Steps To Reproduce

manage user -> edit user->new mail address 12345678@qq.com

alert error APPLICATION ERROR #1201

TagsNo tags attached.

Relationships

duplicate of 0023683 new Can not see way to turn off "disposable email addresses" checking. 

Activities

wangyouworld

wangyouworld

2018-01-09 01:34

reporter   ~0058500

No way, I added user records from the database.

In the revision, it is still not allowed to modify.

wangyouworld

wangyouworld

2018-01-09 01:36

reporter  

img.png (6,584 bytes)
img.png (6,584 bytes)
wangyouworld

wangyouworld

2018-01-09 01:40

reporter   ~0058501

Like abcefg@163.com mail address, is allowed to set up.

atrol

atrol

2018-01-09 03:08

developer   ~0058503

Email address validation can't be turned off at the moment, see 0023683.

As a workaround, remove line qq.com fom file vendor/vboctor/disposable_email_checker/data/domains.txt

wangyouworld

wangyouworld

2018-01-09 03:22

reporter   ~0058505

thank you very much,
The problem has been solved.

Please forgive me English is not good,

No first search before submitting the question,

Thanks again!

--From google translate

Issue History

Date Modified Username Field Change
2018-01-09 01:29 wangyouworld New Issue
2018-01-09 01:34 wangyouworld Note Added: 0058500
2018-01-09 01:36 wangyouworld File Added: img.png
2018-01-09 01:40 wangyouworld Note Added: 0058501
2018-01-09 03:08 atrol Assigned To => atrol
2018-01-09 03:08 atrol Status new => resolved
2018-01-09 03:08 atrol Resolution open => duplicate
2018-01-09 03:08 atrol Note Added: 0058503
2018-01-09 03:08 atrol Relationship added duplicate of 0023683
2018-01-09 03:22 wangyouworld Note Added: 0058505
2018-01-20 07:23 atrol Status resolved => closed