View Issue Details

IDProjectCategoryView StatusLast Update
0023333mantisbtfilterspublic2019-04-21 02:53
Reporterhelfy022 Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.5.1 
Target Version2.21.0Fixed in Version2.21.0 
Summary0023333: sub-project assignments missing from project-specific My View page
Description

Hello,

When an umbrella project has been chosen, no assignments corresponding to any related sub-projects are shown on the My View page. Instead, one must choose the specific sub-project in order to see assigned issues.

Bugs such as the following note that a fix was included in an earlier MantisBT release:

https://www.mantisbt.org/bugs/view.php?id=5914

We are currently using MantisBT core version 2.5.1. Are there any configuration changes that need to be imposed in order to ensure that all project and related sub-projects assignments will be listed in the My View page?

Thanks,
Ryan.

TagsNo tags attached.

Activities

cproensa

cproensa

2017-09-11 07:42

developer   ~0057675

I can't reproduce it.

Are your filters configured by default as simple, or advanced?

helfy022

helfy022

2017-09-11 09:39

reporter   ~0057677

Is there such an option for the "My View" page?

The issue is not observed on "View Issues" page, but "My View" only.

Thanks,
Ryan.

helfy022

helfy022

2017-09-15 10:10

reporter   ~0057725

Hello,

Please let me know if you need any more information in order to understand or reproduce the issue.

Thanks,
Ryan.

Jeremy13560

Jeremy13560

2019-03-22 11:40

reporter   ~0061738

I have exactly the same problem with users on v2.5.1.

You can't reproduce this problem over developer status due to $g_handler_bug_threshold.

If you want to display the "Assign to Me" box in MyView, you can change $g_handle_bug_threshold with a lower level access but your assignement user list will contain all users....
It's not a good solution for me and need to be fixed.

cproensa

cproensa

2019-03-23 16:12

developer   ~0061755

Thanks, i could reproduce it.

Proposed a fix:
https://github.com/mantisbt/mantisbt/pull/1490

Related Changesets

MantisBT: master c225bb8e

2019-03-23 16:05:56

cproensa


Committer: dregad Details Diff
Fix missing boxes in my view page

In My View page, some boxes are discarded if the user don't have
certain permissions. Those checks are performed against the current
project only, however, the boxes may show issues from subprojects
where the user can have those permissions.

With this change, the checks are made for the actual list of projects
that will be included in the filters for those sections.

Fixes: 0023333
Affected Issues
0023333
mod - my_view_page.php Diff File

Issue History

Date Modified Username Field Change
2017-09-08 14:41 helfy022 New Issue
2017-09-11 07:42 cproensa Assigned To => cproensa
2017-09-11 07:42 cproensa Status new => feedback
2017-09-11 07:42 cproensa Note Added: 0057675
2017-09-11 09:39 helfy022 Note Added: 0057677
2017-09-11 09:39 helfy022 Status feedback => assigned
2017-09-15 10:10 helfy022 Note Added: 0057725
2019-03-22 11:40 Jeremy13560 Note Added: 0061738
2019-03-23 16:12 cproensa Note Added: 0061755
2019-03-29 18:01 dregad Changeset attached => MantisBT master c225bb8e
2019-03-29 18:01 cproensa Status assigned => resolved
2019-03-29 18:01 cproensa Resolution open => fixed
2019-03-29 18:01 cproensa Fixed in Version => 2.21.0
2019-03-29 18:06 dregad Target Version => 2.21.0
2019-04-21 02:53 vboctor Status resolved => closed