View Issue Details

IDProjectCategoryView StatusLast Update
0022598mantisbtapi restpublic2017-04-01 00:13
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.2.2 
Target Version2.3.0Fixed in Version2.3.0 
Summary0022598: REST API Framework
Description
  • RESTful API with JSON payloads for requests and responses utilizing Slim Framework.
  • Authentication no support for username and password. API tokens are the authentication mechanism.
  • Enable use of API from web UI As we move more towards javascript calling into backend enable JS to call into REST API via cookie based auth. If cookie authentication is used, it will work even if access to REST API is disabled.
  • Enable plugins to publish their own APIs/routes - It should be easy for plugins to extend the REST API with their specific APIs.
  • Support for Swagger and Swagger UI (see example) - use of swagger provides API meta data, ability to generate client code in all languages, and a web UI to play with the API.
  • Time for Breaking changes - Since this is a new API, we can do breaking changes like removing deprecated functionality, fixing in-consistencies (e.g. sometimes returning a user object and sometimes a user id), dropping username/password support, etc.
  • Re-use of code between SOAP and REST - avoid duplicate logic. Eventually deprecate SOAP.
  • Based on proven framework (Slim Framework) - get a bunch of powerful functionality and a proven framework.
  • Use Composer - It's about time we start transitioning to Composer for new dependencies.
  • Private/Internal API - Created a route group /internal for APIs that are private to the web UI.
TagsNo tags attached.

Relationships

parent of 0022599 closedvboctor Use composer to pull in dependencies 
parent of 0022600 closedvboctor Enable plugins to publish their own REST APIs 
parent of 0022601 closedvboctor Support using REST API from Web UI Javascript 
parent of 0022602 closedvboctor Provide a sandbox for interacting with REST API using Swagger UI 

Activities

Related Changesets

MantisBT: master 16f0fa49

2017-03-30 15:11:51

atrol

Details Diff
Correct call of faultBadRequest

Issue 0022598
mod - api/soap/mc_issue_api.php Diff File

MantisBT: master a8e2711e

2017-03-30 16:58:50

atrol

Details Diff
PHPDoc fix

Issue 0022598
mod - api/soap/mc_api.php Diff File

Issue History

Date Modified Username Field Change
2017-03-29 01:49 vboctor New Issue
2017-03-29 01:49 vboctor Status new => assigned
2017-03-29 01:49 vboctor Assigned To => vboctor
2017-03-29 01:50 vboctor Status assigned => resolved
2017-03-29 01:50 vboctor Resolution open => fixed
2017-03-29 01:50 vboctor Fixed in Version => 2.3.0
2017-03-29 01:50 vboctor Note Added: 0056246
2017-03-29 01:51 vboctor Relationship added parent of 0022599
2017-03-29 01:54 vboctor Relationship added parent of 0022600
2017-03-29 01:55 vboctor Relationship added parent of 0022601
2017-03-29 01:57 vboctor Relationship added parent of 0022602
2017-03-30 15:13 atrol Changeset attached => MantisBT master 16f0fa49
2017-03-30 17:00 atrol Changeset attached => MantisBT master a8e2711e
2017-04-01 00:13 vboctoradmin Status resolved => closed