View Issue Details

IDProjectCategoryView StatusLast Update
0021685mantisbtuipublic2017-04-30 14:48
Reportergrply69Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformOSWindowsOS Version2008 serveur
Product Version2.0.0-beta.2 
Target VersionFixed in Version 
Summary0021685: Dropzone.js error message at each bug detail
Description

This is with Firefox 48 or Internet Explorer 11 in a Tse Session on Windows server 2008.
each time a bug detail is entered, Mantis displays an Html alert

'Dropzone.js does not support older browsers!'

I have added another alert to fileupload_inc.php to display the exception error message and it says:
invalid 'PreviewContainer' option provided. Please provide a CSS selector or a plain HTML element

surely this is linked to
https://github.com/enyo/dropzone/issues/976

Also, having this alert for every bug is somewhat annoying. Maybe it could be disabled when the config_inc.php option is disabled (I tried this...), or displayed only ONE time for a session, or changed to a console.log with the actual error message.
After all, there is not great risk to actually use one of those 'older browsers' with Mantis 2...

Tagsmodern-ui

Relationships

related to 0022140 closedcproensa Getting error dialog when reporting issues and file upload is disabled 

Activities

atrol

atrol

2016-09-12 15:03

developer   ~0054008

PR https://github.com/mantisbt/mantisbt/pull/887

grply69

grply69

2016-09-12 18:39

reporter   ~0054014

Atrol, are you sure this github patch is supposed to fix this particular problem ? I tried it and I could not see any change. I will have more time Thursday, I'll try it again then since my first test was very quick, maybe I misapplied the patch.

atrol

atrol

2016-09-13 03:28

developer   ~0054017

Atrol, are you sure this github patch is supposed to fix this particular problem ?

No, seems I read to cursory (just noticed Dropzone) and confused with another issue.

mantisiator

mantisiator

2017-03-22 17:32

reporter   ~0056165

Hi,
I have reproduced the same problem when using the version 2.0.0.
Everything went well in my implementation until a system update done today by the company system admin. I have to check was was the system update. Do you have any hint to fix that issue please ?

atrol

atrol

2017-03-22 18:01

developer   ~0056166

@grply69 @mantisiator
Are you able to reproduce the issue using latest stable version (2.2.1 at the moment) ?
The underlying dropzone.js has been updated in 2.2.0, see 0022273, thus it might be fixed.

mantisiator

mantisiator

2017-03-22 21:35

reporter   ~0056168

Hi atrol,
I am currenly in version 2.0.0, planning asap to move to 2.2.1
Do you think that the fix proposed in 0022273 can be merged into 2.0.0 as it is ?
Thanks a lot

mantisiator

mantisiator

2017-03-22 23:05

reporter   ~0056169

The merge of the changes does not seem to fix the problem.
This might be due to the fact the js folder differs between both 2.0. and 2.2.1 versions ? Correct ?

mantisiator

mantisiator

2017-03-23 01:08

reporter   ~0056170

What's more - as a workaround to unblock the current users - I have tried :

  • removing the exception raised in the common.js file but his does not help,
  • removing temporarily the attachment feature but this does not help neither.

Do you know any potential other workaround ?
Thanks a lot in advance !

atrol

atrol

2017-03-24 04:38

developer   ~0056181

Last edited: 2017-03-24 04:38

View 2 revisions

Everything went well in my implementation until a system update done today by the company system admin.

Do you know any potential other workaround ?

@mantisiator

it's quite hard to find a workaround as long as I am not able to reproduce the issue.
Furthermore this seems not to be a MantisBT issue as it worked before a system update.

I will set this issue to resolved in a few days since no one seems to be able to provide step by step instructions to reproduce it.

Just a guess: Maybe you use some kind of proxy or web accelerator in your company.

cproensa

cproensa

2017-03-25 08:05

developer   ~0056195

@atrol
seems the error is showed when the user does not have permission to upload attachments

atrol

atrol

2017-03-25 11:02

developer   ~0056198

seems the error is showed when the user does not have permission to upload attachments

Right, this would be a similar or the same issue like related 0022140
But until now @grply69 and @mantisiator did not tell anything about disabled upload or missing upload permissions.

mantisiator

mantisiator

2017-03-25 11:52

reporter   ~0056199

Please note that as a workaround I have de activated the drop feature.
In parallel I am investing the changes done on my computer which I will forward you today
Thanks a lot for this discussion

mantisiator

mantisiator

2017-03-25 12:09

reporter   ~0056200

Here is the update done on Windows. Note that after the problem

  • appeared after the src folder update
  • I then removed the drop feature as a workaround
  • Now I have reset the upload feature and it works correctly. ..only change is the Cisco update....


image001.png (24,955 bytes)
image001.png (24,955 bytes)
Xenos

Xenos

2017-04-21 16:37

reporter   ~0056647

Can Dropzone.js be deactivated when you have to deal with "old browsers" (like FF 52, which is very very old...) and with truely old ones (like I actually do) ?

Xenos

Xenos

2017-04-21 17:11

reporter   ~0056649

} catch (e) {
alert( form.data('dropzone-not-supported') );
}

This alertbox has nothing to do here in js/common.js because the Exception may be raised because there's no Dropzone in the page (just disallow anonymous to upload files but allow them to report bug, log off, and go to a report page to see that alert box).
Just kill this alertbox and everything will be fine. The message it carries (old browser) is totally irrelevant (it's actually a simple exception logging you want to do here).

atrol

atrol

2017-04-21 17:29

developer   ~0056650

the Exception may be raised because there's no Dropzone in the page

This issue is covered by 0022140

Just kill this alertbox and everything will be fine.

This is just a workaround, see 0022140:0054998
The right solution will be the fix of 0022140
https://github.com/mantisbt/mantisbt/pull/1082

atrol

atrol

2017-04-21 17:34

developer   ~0056651

Set to resolved as it might be a duplicate of 0022140 and no one was able to provide instructions how to reproduce the issue without disabled upload.

Issue History

Date Modified Username Field Change
2016-09-11 17:38 grply69 New Issue
2016-09-12 02:15 atrol Tag Attached: modern-ui
2016-09-12 15:03 atrol Note Added: 0054008
2016-09-12 18:39 grply69 Note Added: 0054014
2016-09-13 03:28 atrol Note Added: 0054017
2017-01-09 17:18 atrol Relationship added related to 0022140
2017-03-22 17:32 mantisiator Note Added: 0056165
2017-03-22 18:01 atrol Status new => feedback
2017-03-22 18:01 atrol Note Added: 0056166
2017-03-22 21:35 mantisiator Note Added: 0056168
2017-03-22 23:05 mantisiator Note Added: 0056169
2017-03-23 01:08 mantisiator Note Added: 0056170
2017-03-24 04:38 atrol Note Added: 0056181
2017-03-24 04:38 atrol Note Edited: 0056181 View Revisions
2017-03-25 08:05 cproensa Note Added: 0056195
2017-03-25 11:02 atrol Note Added: 0056198
2017-03-25 11:52 mantisiator Note Added: 0056199
2017-03-25 12:09 mantisiator File Added: image001.png
2017-03-25 12:09 mantisiator Note Added: 0056200
2017-04-21 16:37 Xenos Note Added: 0056647
2017-04-21 17:11 Xenos Note Added: 0056649
2017-04-21 17:29 atrol Note Added: 0056650
2017-04-21 17:34 atrol Assigned To => atrol
2017-04-21 17:34 atrol Status feedback => resolved
2017-04-21 17:34 atrol Resolution open => unable to reproduce
2017-04-21 17:34 atrol Note Added: 0056651
2017-04-30 14:48 vboctor Status resolved => closed