View Issue Details

IDProjectCategoryView StatusLast Update
0015276mantisbtcustom fieldspublic2017-10-08 23:55
ReporterfytsAssigned Tosyncguru 
PrioritynormalSeverityfeatureReproducibilityalways
Status assignedResolutionfixed 
Product Version1.2.12 
Target Version2.8.0Fixed in Version 
Summary0015276: Custom field "Date" 31 days every month.
Description

For example:
February still display 31 days.

Hope it automatically changes the correct number of days.

TagsNo tags attached.

Relationships

related to 0004454 assignedsyncguru 31 February ??? 
related to 0008957 assignedsyncguru Date Selector for Custom Fields 
child of 0015281 assignedsyncguru Consistent user interface for date fields 

Activities

Sergiodf

Sergiodf

2012-12-11 20:53

reporter   ~0034528

Last edited: 2012-12-11 20:56

View 2 revisions

I think the automatic change suggested is not good.
When using the date format dd/MM/yyyy, if a month is already selected and it has 30 days, you have to change the month first and then go "back" and pick a day.

A little further, I think the best UI is a plain text input so you can type a date completely using the numpad (besides the javascript calendar-like date selector, discussed in 0008957, for the people with the hand "tied to the mouse").

dregad

dregad

2012-12-12 06:04

developer   ~0034533

@atrol - I would personally have closed this as duplicate of 0004454.

@sergiodf - I agree with your suggestion of single text field + date picker as a better UI for date entry

atrol

atrol

2012-12-12 07:01

developer   ~0034534

We have no single place in code where we deal with date/time and calendar

For example we have also "Due Date" which uses the calendar control if JavaScript is enabled and also the "Date Order" field for project versions.

This one is for custom fields, 0004454 is for filters.
If you fix one of them, the other one is not fixed.
That's why I didn't resolve as duplicate.

dregad

dregad

2012-12-12 07:37

developer   ~0034535

Last edited: 2012-12-12 11:00

View 2 revisions

OK fair enough, that's a good point.

I think we should consider standardizing these date fields at some point, maybe create a parent issue to set as target in next release and link this and any other related issue.

EDIT: parent created, see 0015281

fyts

fyts

2012-12-12 11:21

reporter   ~0034536

I perfer to use the single text field + JavaScript select UI like http://www.booking.com
It saves many time for me.
I will try to modify my site code first. Thanks for attention :")

atrol

atrol

2017-03-30 15:52

developer   ~0056284

Fixed after changes to fix 0008957

cproensa

cproensa

2017-04-16 18:50

developer   ~0056591

Reopened. Due to regressions, the changes have been reverted and will be targeted to next release

Issue History

Date Modified Username Field Change
2012-12-11 16:05 fyts New Issue
2012-12-11 16:48 atrol Relationship added related to 0004454
2012-12-11 16:48 atrol Relationship added related to 0008957
2012-12-11 20:53 Sergiodf Note Added: 0034528
2012-12-11 20:56 Sergiodf Note Edited: 0034528 View Revisions
2012-12-12 06:04 dregad Note Added: 0034533
2012-12-12 07:01 atrol Note Added: 0034534
2012-12-12 07:37 dregad Note Added: 0034535
2012-12-12 10:56 dregad Relationship added child of 0015281
2012-12-12 10:57 dregad Status new => acknowledged
2012-12-12 11:00 dregad Note Edited: 0034535 View Revisions
2012-12-12 11:21 fyts Note Added: 0034536
2017-03-30 15:52 atrol Assigned To => syncguru
2017-03-30 15:52 atrol Status acknowledged => resolved
2017-03-30 15:52 atrol Resolution open => fixed
2017-03-30 15:52 atrol Fixed in Version => 2.3.0
2017-03-30 15:52 atrol Note Added: 0056284
2017-03-30 16:09 atrol Target Version => 2.3.0
2017-04-01 00:13 vboctoradmin Status resolved => closed
2017-04-16 18:50 cproensa Status closed => assigned
2017-04-16 18:50 cproensa Fixed in Version 2.3.0 =>
2017-04-16 18:50 cproensa Target Version 2.3.0 => 2.4.0
2017-04-16 18:50 cproensa Note Added: 0056591
2017-04-30 14:53 vboctoradmin Target Version 2.4.0 => 2.5.0
2017-06-04 16:19 atrol Target Version 2.5.0 => 2.6.0
2017-09-03 18:50 vboctor Target Version 2.6.0 => 2.7.0
2017-10-08 23:55 vboctor Target Version 2.7.0 => 2.8.0