View Issue Details

IDProjectCategoryView StatusLast Update
0012796mantisbtjavascriptpublic2016-03-13 17:58
Reporterjdpipe 
Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version10.04
Product Version1.2.4 
Target VersionFixed in Version 
Summary0012796: 'javascript' subdirect should be renamed
Description

It's strange, but on my Ubuntu 10.04 system, the file

/etc/apache2/conf.d/javascript-common.conf

contains the line

Alias /javascript /usr/share/javascript/

This means that in default Apache installations on this platform, any URL starting with /javascript will not be accessible in the usual way as a subdirectory of the DocumentRoot, but will be redirected to that /usr/share/javascript folder.

This isn't really great planning on the part of Ubuntu, but perhaps the easy way to avoid confusions for new Mantis installations would be to rename the javascript directory to something like 'js' instead?

TagsNo tags attached.

Relationships

duplicate of 0020646 closedcommunity Failure to load scripts from "javascript" folder 
related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 
has duplicate 0017032 closedatrol Datepicker Error 
related to 0015964 closedatrol Select all in view list is not working 

Activities

Lapinkiller

Lapinkiller

2011-06-01 04:01

reporter   ~0028882

I think it's Ubuntu which have to change this... and not websites...

jdpipe

jdpipe

2011-11-08 23:10

reporter   ~0030202

Ubuntu has put the bug report on their 'wishlist'. So don't expect anything to happen here...

https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/791625

atrol

atrol

2012-03-17 05:56

developer   ~0031486

What does resolution "fixed" + fixed in version "git trunk" mean?
Is the javascript directory renamed?

Closing the issue leaded to the follwowing entry in bugtracker of Ubuntu

Changed in mantis:
status: New → Fix Released

grangeway

grangeway

2012-10-20 19:59

reporter   ~0033290

this is fixed in the mantis-2.x branch

grangeway

grangeway

2013-04-05 17:56

reporter   ~0036221

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

atrol

atrol

2016-02-29 03:05

developer   ~0052599

Closing the older issue as activity takes place at 0020646.

Issue History

Date Modified Username Field Change
2011-02-23 05:27 jdpipe New Issue
2011-06-01 04:01 Lapinkiller Note Added: 0028882
2011-11-08 23:10 jdpipe Note Added: 0030202
2012-03-03 09:00 grangeway Status new => resolved
2012-03-03 09:00 grangeway Fixed in Version => git trunk
2012-03-03 09:00 grangeway Resolution open => fixed
2012-03-03 09:00 grangeway Assigned To => grangeway
2012-03-17 05:56 atrol Note Added: 0031486
2012-03-17 05:56 atrol Status resolved => feedback
2012-03-17 05:56 atrol Resolution fixed => reopened
2012-10-20 19:59 grangeway Note Added: 0033290
2012-10-20 19:59 grangeway Status feedback => resolved
2012-10-20 19:59 grangeway Fixed in Version git trunk => 1.3.0-beta.1
2012-10-20 19:59 grangeway Resolution reopened => fixed
2013-04-05 17:56 grangeway Status resolved => acknowledged
2013-04-05 17:56 grangeway Note Added: 0036221
2013-04-05 18:56 grangeway Relationship added related to 0015721
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2013-04-27 17:22 atrol Tag Attached: 2.0.x fixed
2013-04-27 17:22 atrol Assigned To grangeway =>
2013-04-27 17:22 atrol Status resolved => new
2013-04-27 17:22 atrol Resolution fixed => open
2013-04-27 17:22 atrol Fixed in Version 1.3.0-beta.1 =>
2013-06-04 04:34 atrol Relationship added related to 0015964
2014-03-04 08:52 atrol Relationship added has duplicate 0017032
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-09-23 18:06 grangeway Tag Detached: 2.0.x fixed
2016-02-29 03:05 atrol Assigned To => atrol
2016-02-29 03:05 atrol Status new => resolved
2016-02-29 03:05 atrol Resolution open => duplicate
2016-02-29 03:05 atrol Note Added: 0052599
2016-02-29 03:05 atrol Relationship added duplicate of 0020646
2016-03-13 17:58 atrol Status resolved => closed