MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009645mantisbtemailpublic2008-09-18 05:352008-11-27 17:42
ReporterTyredating 
Assigned Tovboctor 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSServer 2003OS VersionR2
Product Version1.2.0a2 
Target VersionFixed in Version 
Summary0009645: Unable to send email throught smtp with mercury (solved)
DescriptionWhen you setup a mantis with a mercury smtp server, you will be in most cases unable to send emails with another computer than the one where Mantis is installed.
In mercury logs, you will see this message ""554 Invalid HELO format" on valid HELOs/EHLO".It is due to the RFC compliance from mercury which isn't RFC compliant.
Here is the fix :
locate "transfltr.mer" in mercury folder, edit it with notepad or whatever.
 Locate this line at the end of the file :
H, "[EHeh][EHeh]LO +[0-9]+.[0-9]+.[0-9]+.[0-9]*", R, "554 Invalid HELO format"
comment it out (add # at the begining of the line) restart the mail server then.
If you want to turn mercury into RFC compliant, add this line above the one you commented out :
H, "[EHeh][EHeh]LO +[0-9]+.[0-9]+.[0-9]+.[0-9]+.*", X, ""

and voila :-)
TagsNo tags attached.
Attached Files

- Relationships
child of 0004350closeddhx FAQ 

-  Notes
User avatar (0020085)
vboctor (administrator)
2008-11-27 17:42

Thanks for documenting this tip. I've linked this issue to the FAQ issue.

- Issue History
Date Modified Username Field Change
2008-09-18 05:35 Tyredating New Issue
2008-11-27 17:41 vboctor Relationship added child of 0004350
2008-11-27 17:42 vboctor Note Added: 0020085
2008-11-27 17:42 vboctor Status new => resolved
2008-11-27 17:42 vboctor Resolution open => no change required
2008-11-27 17:42 vboctor Assigned To => vboctor
2008-11-27 17:42 vboctor Status resolved => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.0610 seconds.
memory usage: 2,949 KB
Powered by Mantis Bugtracker