View Issue Details

IDProjectCategoryView StatusLast Update
0006895mantisbtdb oraclepublic2014-12-08 00:34
ReportermechantflouAssigned Todregad 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.1 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0006895: install mantis with oracle (driver oci8)
Description

list of file you have to modify

config-inc.php
install.php
database-api.php
custom_field-api.php

****config-inc.php

keep $g_hostname blank

$g_hostname='';
$g_db_username='username';
$g_db_password='password';
$g_db_database_name='database name';
$g_db_type='oci8;

****install.php

add in line 211 in switch($f_db_type)

case 'oci8:
$t_support=function_exists('OCILogon');
break;

add in the driver list this line

<option value="oci8">Oracle(oci8)</option>

****custom_field-api.php

replace the query in line 629 with

 $query = "SELECT cft.id id, cft.name name
            FROM $t_custom_field_table cft, $t_user_table ut, $t_project_table pt, $t_custom_field_project_table cfpt
                LEFT JOIN $t_project_user_list_table pult 
                    on cfpt.project_id = pult.project_id and pult.user_id = $t_user_id
            WHERE cft.id = cfpt.field_id AND cfpt.project_id = pt.id AND ut.id = $t_user_id AND 
                ( pt.view_state = $t_pub OR 
                ( pt.view_state = $t_priv and pult.user_id = $t_user_id ) OR 
                ( pult.user_id is null and ut.access_level $t_access_clause ) )
            GROUP BY cft.id, cft.name
            ORDER BY cft.name ASC";

**database-api.php

add in function db_helper_compare_days

case 'oci8' : return "(($p_date1 - $p_date2)".$p_limitstring.")";

Really, with all issues, mantis run with database oracle

TagsNo tags attached.

Relationships

child of 0013227 closeddregad Oracle DB support multiple issues 

Activities

mechantflou

mechantflou

2006-03-29 05:27

reporter   ~0012436

You need also modify prefix and suffix db table in config-inc.php because table name can be too long and generate much errors with oracle

****line 1199

$g_db_table_prefix      = 'm';
$g_db_table_suffix      = '_tbl';
vboctor

vboctor

2006-04-25 08:02

manager   ~0012712

What was wrong with the original custom fields query? I've noticed that the only difference is that in the original version there was "name as alias" rather than "name alias".

I also didn't apply the change for shortening the table prefix and suffix, is this really required? If so, then we need to change the install the use such short prefixes for Oracle when config_inc.php doesn't exist.

vboctor

vboctor

2006-04-25 08:03

manager   ~0012713

The database_api.php and install.php changes are now committe in CVS and will be included in Mantis v1.1.

mechantflou

mechantflou

2006-04-26 10:19

reporter   ~0012729

this is the message

The following error has occurred:

ORA-00972: identifier is too long

Issue History

Date Modified Username Field Change
2006-03-29 05:06 mechantflou New Issue
2006-03-29 05:27 mechantflou Note Added: 0012436
2006-04-25 08:02 vboctor Note Added: 0012712
2006-04-25 08:02 vboctor Status new => feedback
2006-04-25 08:03 vboctor Note Added: 0012713
2006-04-26 10:19 mechantflou Note Added: 0012729
2006-05-23 20:48 ipardo Sponsorship Added ipardo: US$ 10
2006-05-23 20:48 ipardo Sponsorship Total 0 => 10
2011-09-09 12:28 dregad Relationship added child of 0013227
2013-10-17 12:50 dregad Status feedback => resolved
2013-10-17 12:50 dregad Fixed in Version => 1.3.0-beta.1
2013-10-17 12:50 dregad Resolution open => fixed
2013-10-17 12:50 dregad Assigned To => dregad
2013-10-17 12:51 dregad Target Version => 1.3.0-beta.1
2014-04-12 19:39 grangeway Issue cloned: 0017213
2014-12-08 00:34 vboctor Status resolved => closed