View Issue Details

IDProjectCategoryView StatusLast Update
0022985mantisbtinstallationpublic2017-06-17 17:52
Reporter7h3ju57Assigned Todregad 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.0 
Target Version2.5.1Fixed in Version2.5.1 
Summary0022985: Initial installation does not continue after clicking install
Description

after filling in all the field during the initial installation, when you finish and click install nothing happens.

looks to have been a miss place if statement.

TagsNo tags attached.

Relationships

related to 0022850 closeddregad Installation page layout and style issues 
has duplicate 0023010 resolvedatrol no button to click to continue the installation 
has duplicate 0023022 resolvedatrol Can't complete installation of mantis 2.5.0 

Activities

7h3ju57

7h3ju57

2017-06-08 22:37

reporter   ~0057048

https://github.com/mantisbt/mantisbt/pull/1121

7h3ju57

7h3ju57

2017-06-09 07:58

reporter   ~0057055

This is from a fresh install of mantis 2.5.0, no preconfigured database.



mantis25-nowork.png (60,927 bytes)
mantis25-nowork.png (60,927 bytes)
7h3ju57

7h3ju57

2017-06-09 08:06

reporter   ~0057056

And after fix all works as expected.



mantis25-works.png (74,795 bytes)
mantis25-works.png (74,795 bytes)
atrol

atrol

2017-06-09 08:26

developer   ~0057057

No time to have a deeper look at the moment, might be caused by changes to fix 0022850

7h3ju57

7h3ju57

2017-06-09 09:17

reporter   ~0057058

its definitely was caused by that commit, looks like the if statement was placed in one curly brace too high, so i put in PR https://github.com/mantisbt/mantisbt/pull/1121 to fix it.

dregad

dregad

2017-06-09 13:13

developer   ~0057059

Confirmed regression introduced by MantisBT master 624f9057

dregad

dregad

2017-06-09 13:36

developer   ~0057060

Increasing severity to block, as this is completely preventing installation.

Related Changesets

MantisBT: master 624f9057

2017-05-10 06:59:03

dregad

Details Diff
Install: fix layout of check and options sections

Incorrect closing of tables and divs within the various conditional
blocks caused the title of the 'Installation Options' section to be
displayed as a "sub-table" under the 'Checking Installation' section,
followed by the actual install checks and finally the list of
installation options.

This commit moves the closing tags as appropriate, so that
- checks are listed as a table under 'Checking Installation' section
- 'Installation Options' is displayed as an independent section below
the checks

Fixes 0022850
mod - admin/install.php Diff File

MantisBT: master-2.5 0de67c37

2017-06-08 20:38:16

7h3ju57


Committer: dregad Details Diff
Fix installer blocked at stage 2

Commit 624f9057798a010b15ca174e11b85ea0136637f1 introduced a regression
causing the installer to stop at stage 2, i.e. the database was never
created.

Fixes 0022985

Signed-off-by: Damien Regad <dregad@mantisbt.org>

Rewrote original commit's message, correct author's e-mail.
mod - admin/install.php Diff File

Issue History

Date Modified Username Field Change
2017-06-08 20:48 7h3ju57 New Issue
2017-06-08 22:37 7h3ju57 Note Added: 0057048
2017-06-09 07:58 7h3ju57 File Added: mantis25-nowork.png
2017-06-09 07:58 7h3ju57 Note Added: 0057055
2017-06-09 08:06 7h3ju57 File Added: mantis25-works.png
2017-06-09 08:06 7h3ju57 Note Added: 0057056
2017-06-09 08:26 atrol Note Added: 0057057
2017-06-09 09:17 7h3ju57 Note Added: 0057058
2017-06-09 12:54 dregad Relationship added related to 0022850
2017-06-09 12:54 dregad Assigned To => dregad
2017-06-09 12:54 dregad Status new => assigned
2017-06-09 12:54 dregad Target Version => 2.5.1
2017-06-09 13:13 dregad Note Added: 0057059
2017-06-09 13:13 dregad Changeset attached => MantisBT master 624f9057
2017-06-09 13:34 dregad Changeset attached => MantisBT master-2.5 0de67c37
2017-06-09 13:34 dregad Status assigned => resolved
2017-06-09 13:34 dregad Resolution open => fixed
2017-06-09 13:34 dregad Fixed in Version => 2.5.1
2017-06-09 13:36 dregad Severity major => block
2017-06-09 13:36 dregad Note Added: 0057060
2017-06-15 03:43 atrol Relationship added has duplicate 0023010
2017-06-15 13:00 atrol Relationship added has duplicate 0023022
2017-06-17 17:52 vboctor Status resolved => closed