View Issue Details

IDProjectCategoryView StatusLast Update
0022905mantisbtcode cleanuppublic2017-06-04 14:58
ReporterdregadAssigned Todregad 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.5.0Fixed in Version2.5.0 
Summary0022905: The URL of the return button in breadcrumbs div has a trailing '?'
Description

This happens on pages where the return URL is a single page, without query parameters (e.g. my_view_page.php). In that case, the trailing ? is actually not necessary and should not be appended.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 486e1a7e

2017-05-20 05:57:34

dregad

Details Diff
Only append query string to return URL when not blank

The target URL for the 'Login' button in the breadcrumbs div had a
trailing '?' due to appending QUERY_STRING even when no query params
are defined.

Adding a check to only add it when QUERY_STRING is not blank fixes the
problem.

Fixes 0022905
mod - core/layout_api.php Diff File

Issue History

Date Modified Username Field Change
2017-05-20 07:23 dregad New Issue
2017-05-20 07:24 dregad Changeset attached => MantisBT master 486e1a7e
2017-05-20 07:24 dregad Assigned To => dregad
2017-05-20 07:24 dregad Status new => resolved
2017-05-20 07:24 dregad Resolution open => fixed
2017-05-20 07:24 dregad Fixed in Version => 2.5.0
2017-06-04 14:58 vboctor Status resolved => closed