MantisBT

View Issue Details Jump to Notes ] Wiki ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0013496mantisbtapi soappublic2011-11-08 05:052013-04-06 08:22
Reporterrombert 
Assigned Torombert 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version1.2.9Fixed in Version1.2.9 
Summary0013496: Send all dates in the GMT timezone
DescriptionAs discussed in https://sourceforge.net/mailarchive/forum.php?thread_name=CAA3RzWNoxz3F1moXM5TStu7PEKn3K8C7rr10h4Gpd5Z%2BNE%3D%2Bow%40mail.gmail.com&forum_name=mantisbt-soap-dev [^] , we will send date and times in the GMT timezone.
TagsNo tags attached.
Attached Files

- Relationships
related to 0015721closedgrangeway mantisbt Functionality to consider porting to master-2.0.x 
child of 0013486closedvboctor MantisTouch Adjust timestamps for time zones 

-  Notes
User avatar (0030320)
belfar (reporter)
2011-11-23 18:39

teste
User avatar (0036365)
grangeway (developer)
2013-04-05 17:57

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

- Related Changesets
MantisBT: master fd8b2f09
Timestamp: 2011-11-09 08:05:59
Author: rombert
Details ] Diff ]
Fix 0013496: Send all dates in the GMT timezone

Since NuSOAP's conversion of dates to the Etc/GMT timezone is not
what we want, rely on PHP's built in formatting to generate the
correct time zone offset.
mod - api/soap/mc_api.php Diff ] File ]
mod - api/soap/mc_filter_api.php Diff ] File ]
mod - api/soap/mc_issue_api.php Diff ] File ]
mod - api/soap/mc_project_api.php Diff ] File ]
MantisBT: master-1.2.x d784eb75
Timestamp: 2011-11-09 08:05:59
Author: rombert
Details ] Diff ]
Fix 0013496: Send all dates in the GMT timezone

Since NuSOAP's conversion of dates to the Etc/GMT timezone is not
what we want, rely on PHP's built in formatting to generate the
correct time zone offset.
mod - api/soap/mc_api.php Diff ] File ]
mod - api/soap/mc_filter_api.php Diff ] File ]
mod - api/soap/mc_issue_api.php Diff ] File ]
mod - api/soap/mc_project_api.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2011-11-08 05:05 rombert New Issue
2011-11-09 11:01 rombert Assigned To => rombert
2011-11-09 11:01 rombert Status confirmed => assigned
2011-11-09 16:26 rombert Status assigned => resolved
2011-11-09 16:26 rombert Resolution open => fixed
2011-11-09 16:26 rombert Fixed in Version => 1.2.9
2011-11-09 17:19 rombert Changeset attached => MantisBT master fd8b2f09
2011-11-09 17:19 rombert Changeset attached => MantisBT master-1.2.x d784eb75
2011-11-23 18:39 belfar Note Added: 0030320
2011-12-13 00:59 vboctor Relationship added child of 0013486
2012-01-19 11:47 dregad Relationship added has duplicate 0013608
2012-03-03 21:45 vboctor Status resolved => closed
2013-04-05 17:57 grangeway Status closed => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036365
2013-04-05 18:17 grangeway Relationship added related to 0015721
2013-04-06 03:42 dregad Status acknowledged => closed
2013-04-06 07:23 grangeway Status closed => acknowledged
2013-04-06 08:22 grangeway Status acknowledged => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.0720 seconds.
memory usage: 3,065 KB
Powered by Mantis Bugtracker