MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011770Plugin - EmailReporting[All Projects] Generalpublic2010-04-08 11:062011-08-25 16:55
Reporterfilmerkl 
Assigned ToSL-Gundam 
PriorityurgentSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformWindowsOSWindows 2003 ServerOS Version2003 Server
Product Version 
Target VersionFixed in Version 
Summary0011770: Problem with plugin Email Reporting
DescriptionHi all,

I have recently installed Mantis plus the mentioned plugin, the whole configuration is:
 - system Windows 2003 Server
 - MySQL db version 5.1
 - Mantis 1.2.0
 - plugin Email reporting 0.7.9-DEV

The thing that is important to me is for all the users to be able to create issues in Mantis by sending email. I have installed and configured everything according to documenation and it works - well, most of the time: I have one problem I haven't been able to solve. The problem I need help with concerns automatization: everything works if I manually get emails from POP3 account to mantis using webserver, but it sometimes crashes when I try the other method - to schedule a job with php.exe running the script.

Details:
 - documentation says that you can either via webserver or via commandline with php.exe
 - via webserver you can do it manually just clicking "/plugins/EmailReporting/scripts/bug_report_mail.php" link or you can set up mantis to do it everytime someone visits the page
 - you can also create a batch with php.exe running the very same php script and schedule it as a reapating tasks
 - with simple mails all the methods above works
 - with some mails, html ones with mime content and footnote, the only method that works is to manually click link on the page; if you do so, the mail is parsed and the image from the footnote is treated as attachment and becomes properly a part of mantis issue; however if you don't do it manully but instead you choose the option that makes mantis webserver to do it triggered by the site visit you can see "SYSTEM WARNING: fsockopen() [function.fsockopen]: unable to connect to 10.0.253.34:0 (Failed to parse address "10.0.253.34")" on the screen; if leave the job to commandline job, you get:
C:\>c:\php\php.exe c:\Inetpub\wwwroot\mantis\plugins\EmailReporting\scripts\bug_
report_mail.php
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.or [^]
g/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
        <link rel="stylesheet" type="text/css" href="C:/Inetpub/wwwroot/mantis/c
ss/default.css" />
        <script type="text/javascript" language="JavaScript"><!--
                if(document.layers) {document.write("<style>td{padding:0px;}<\/s
tyle>")}
        // --></script>
        <meta http-equiv="Content-type" content="text/html; charset=utf-8" />
        <meta http-equiv="Pragma" content="no-cache" />
        <meta http-equiv="Cache-Control" content="no-cache" />
        <meta http-equiv="Pragma-directive" content="no-cache" />
        <meta http-equiv="Cache-Directive" content="no-cache" />
        <meta http-equiv="Expires" content="Thu, 08 Apr 2010 12:40:06 GMT" />
        <link rel="shortcut icon" href="C:/Inetpub/wwwroot/mantis/images/favicon
.ico" type="image/x-icon" />
        <link rel="search" type="application/opensearchdescription+xml" title="M
antisBT: Text Search" href="http://helpdesk.orbistravel.pl/browser_search_plugin [^]
.php?type=text" /> <link rel="search" type="application/opensearchdescripti
on+xml" title="MantisBT: Issue Id" href="http://helpdesk.orbistravel.pl/browser_ [^]
search_plugin.php?type=id" /> <title>MantisBT</title>
<script type="text/javascript" src="C:/Inetpub/wwwroot/mantis/javascript/min/com
mon.js"></script>
<script language="javascript">var loading_lang = "Ładuję...";</script><script
type="text/javascript" src="C:/Inetpub/wwwroot/mantis/javascript/min/ajax.js"></
script>
</head>
<body>
<div align="left"><a href="my_view_page.php"><img border="0" alt="Mantis Bug Tra
cker" src="C:/Inetpub/wwwroot/mantis/images/mantis_logo.gif" /></a></div>
<
div align="center"><table class="width50" cellspacing="1"><tr><td class="form-ti
tle">APPLICATION ERROR 0000401</td></tr><tr><td><p class="center" style="color:red"
>B┼é─ůd wykonania zapytania w bazie danych 1366 ÔÇô Incorrect string value: '\xB
3obuck...' for column 'description' at row 1 dla zapytania INSERT INTO mantis_bu
g_text_table

                                            ( description, steps_to_reproduce, a
dditional_information )

                                          VALUES

                                            ( ?,?,?).

</td></tr><tr><td><p cl
ass="center">Prosz─Ö u┼╝y─ç przycisku ÔÇ×WsteczÔÇŁ w przegl─ůdarce by powr├│ci─ç
 do poprzedniej strony. Tam mo┼╝na poprawi─ç to co spowodowa┼éo b┼é─ůd lub wybra
─ç inn─ů operacj─Ö. Mo┼╝na r├│wnie┼╝ klikn─ů─ç opcj─Ö w g├│rnym menu, aby przej┼
Ť─ç bezpo┼Ťrednio do innej sekcji.

</td></tr></table></div></body>
</html>

plz hlp anybody because there is no info on the web...
TagsNo tags attached.
Attached Files? file icon config_defaults_inc.php [^] (116,474 bytes) 2010-04-08 11:09
? file icon config_inc.php [^] (3,587 bytes) 2010-04-08 11:09 [Show Content]
? file icon php.ini [^] (50,262 bytes) 2010-04-08 11:10

- Relationships

-  Notes
User avatar (0027749)
SL-Gundam (manager)
2010-12-29 09:12

This "... or you can set up mantis to do it everytime someone visits the page" functionality has been removed in 0.8.0

Can you check whether this problem persists in newer version (0.8.4 is the latest atm)

See 0004286
User avatar (0029500)
SL-Gundam (manager)
2011-08-17 21:42

Assuming it has been fixed

Closing issue

- Issue History
Date Modified Username Field Change
2010-04-08 11:06 filmerkl New Issue
2010-04-08 11:09 filmerkl File Added: config_defaults_inc.php
2010-04-08 11:09 filmerkl File Added: config_inc.php
2010-04-08 11:10 filmerkl File Added: php.ini
2010-12-29 09:12 SL-Gundam Note Added: 0027749
2011-05-09 07:52 dhx Project mantisbt => Plugin - EmailReporting
2011-05-09 07:52 dhx Category email => General
2011-08-17 21:41 SL-Gundam Assigned To => SL-Gundam
2011-08-17 21:41 SL-Gundam Status new => assigned
2011-08-17 21:42 SL-Gundam Note Added: 0029500
2011-08-17 21:42 SL-Gundam Status assigned => resolved
2011-08-17 21:42 SL-Gundam Resolution open => fixed
2011-08-25 16:55 SL-Gundam Status resolved => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.1141 seconds.
memory usage: 3,015 KB
Powered by Mantis Bugtracker