View Issue Details

IDProjectCategoryView StatusLast Update
0010242mantisbtfeaturepublic2016-10-02 18:41
ReportersgruendelAssigned Todregad 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.1.6 
Target Version1.3.2Fixed in Version1.3.2 
Summary0010242: Copy Versions From / To should (optionally) update existing versions
Description

When I change an existing Project Version to "released" and set "timestamp" to release date, I have to repeat this for all subprojects. It would be nice if "Copy Version From / To" would not only copy new entries, but also update existing entries.

TagsNo tags attached.

Relationships

related to 0021693 closeddregad Copy of Versions from one project to another project does not copy all fields 

Activities

Related Changesets

MantisBT: master-1.3.x 9f5dfad8

2016-09-17 06:05:53

dregad

Details Diff
Update existing versions when copying from project

Until now, the "Copy Versions From/To" buttons in Manage Projects page
were only adding new versions.

The code has been amended to also update versions existing in the target
project.

Note that since the copy currently ignores obsolete versions, those
marked as such in the source project after an earlier copy operation
will *not* be updated in the target project.

Fixes 0010242
mod - manage_proj_ver_copy.php Diff File

Issue History

Date Modified Username Field Change
2009-03-24 04:32 sgruendel New Issue
2016-09-17 08:13 dregad Relationship added related to 0021693
2016-09-17 09:08 dregad Assigned To => dregad
2016-09-17 09:08 dregad Status new => assigned
2016-09-17 09:08 dregad Severity major => minor
2016-09-17 09:08 dregad Target Version => 1.3.2
2016-09-17 09:08 dregad Note Added: 0054035
2016-09-21 04:03 dregad Changeset attached => MantisBT master-1.3.x 9f5dfad8
2016-09-21 04:03 dregad Status assigned => resolved
2016-09-21 04:03 dregad Resolution open => fixed
2016-09-21 04:03 dregad Fixed in Version => 1.3.2
2016-10-02 18:41 vboctor Status resolved => closed