After instal, Manage Email Reporting shows a blank screen

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Developer, Contributor

Post Reply
JPK
Posts: 5
Joined: Nov 23, 2016 2:05 am

After instal, Manage Email Reporting shows a blank screen

Post by JPK »

Hello

I've just upgrade our Mantis Instal from 1.2.12 to 1.3. All steps run ok, as database update...
Then I updated Email Reporting from 0.9.0-DEV to 0.9.2
MantisBT is hosted in a CentOS VM, running Apache and mySQL.

In Mantis Administration, I have the "manage plug in" panel showing the right version of EmailReporting plug in.

But as I click on the "Manage Email Reporting" link, it shows a blank screen with no form to review or change parameters.
In fact, all the interface of Mantis is showed, header, main menu bar, admin sub menu... But below the screen is blank, just after the link ""Manage Email Reporting" and there is no footer...
In the rendered code, no </body>, no </html>...
In firebug "NetWork" Pannel the URL http://MYMANTISBTDOMAIN/plugin.php?page ... ge_mailbox throws a 500 server error...

When I run the "/plugin.php?page=EmailReporting/bug_report_mail" to retreive mail, nothing happens. Although it worked perfectly before upgrading.

- In the database, in "Mantis config" table, we have 17 lines with parameters concerning "plugin_EmailReporting_..."

- I checked permissions on the plugin folder and file in the server... And others thing to check and make it run.. No success

Has anyone a hint about that issue ?
Thx for advices.
JP

SL-Gundam
Posts: 606
Joined: Jul 06, 2011 9:17 am

Re: After instal, Manage Email Reporting shows a blank scree

Post by SL-Gundam »

Strange

Please do the following

Add this code to your config_inc.php

Code: Select all

$g_show_detailed_errors	= ON;

$g_display_errors = array(
E_WARNING => 'halt',
E_NOTICE => 'halt',
E_USER_ERROR => 'halt',
E_USER_WARNING => 'halt',
E_USER_NOTICE => 'halt'
); 
Try visiting the page in question again.

If no error is shown, please check your php log to see if the error s logged there

JPK
Posts: 5
Joined: Nov 23, 2016 2:05 am

Re: After instal, Manage Email Reporting shows a blank scree

Post by JPK »

Hey.

Added the provided code to my config file...
Nothing more on screen.

Always the error 500 error when running "http://MyMANTISBT/plugin.php?page=Email ... ge_mailbox"

I'm going to activate PHP logs to check if anything in when running the request.

JP

JPK
Posts: 5
Joined: Nov 23, 2016 2:05 am

Re: After instal, Manage Email Reporting shows a blank scree

Post by JPK »

Thank to SL-Gundam for your suggestion to activate PHP log, in which I can see :
"PHP Fatal error: Can't use function return value in write context in /machine_PATH_TO_bugtrack/plugins/EmailReporting/core/config_api.php on line 912"
I guess this leads to the 500 server error..

I went in file to comment the code ...

Code: Select all

	# output a option list with all users who have at least global reporter rights
	function ERP_custom_function_print_reporter_option_list( $p_sel_value )
	{
		$t_user_ids = (array) $p_sel_value;

		if ( !empty( $t_user_ids ) )
		{
			foreach ( $t_user_ids AS $t_single_user_id )
			{
				/*
				if ( !user_exists( $t_single_user_id ) || empty( user_get_accessible_projects( $t_single_user_id ) ) )
				{
					echo '<option value="' . $t_single_user_id . '" selected class="negative">' . plugin_lang_get( 'missing_user', 'EmailReporting' ) . ': ' . $t_single_user_id . '</option>';
				}
				*/
			}
		}

		print_user_option_list( $t_user_ids, ALL_PROJECTS );
	}
The "Manage Email Reporting" is back !

I may investigate more, but maybe it happens after an update, when something wrong with users ??

SL-Gundam
Posts: 606
Joined: Jul 06, 2011 9:17 am

Re: After instal, Manage Email Reporting shows a blank scree

Post by SL-Gundam »

This is an issue with older PHP 5.x versions.
See this topic: http://www.mantisbt.org/forums/viewtopi ... 69&p=59765

The issue is fixed in the current 0.9.3-DEV
https://github.com/mantisbt-plugins/Ema ... 3642d95191

It was the first change we made for 0.9.3-DEV several months ago

I suggest you upgrade to 0.9.3-DEV

JPK
Posts: 5
Joined: Nov 23, 2016 2:05 am

Re: After instal, Manage Email Reporting shows a blank scree

Post by JPK »

Well SL-Gundam, thanks for you help on the topic.

Have a good day
JP

SL-Gundam
Posts: 606
Joined: Jul 06, 2011 9:17 am

Re: After instal, Manage Email Reporting shows a blank scree

Post by SL-Gundam »

Hope you don't have any further issues, otherwise you know where to find us

Good luck

Post Reply