"Check Installation" fails

Post about your customizations to share with others.

Moderators: Developer, Contributor

Post Reply
federico
Posts: 36
Joined: Mar 27, 2019 12:35 pm

"Check Installation" fails

Post by federico » Apr 16, 2019 2:00 am

Why this installation check fails?
Version of PHP installed is at least 5.5.0
PHP version 7.1.26 is currently installed on this server. FAIL
My mantisbt version is "2.20.0"

Thanks

cas
Posts: 668
Joined: Mar 11, 2006 11:08 am
Contact:

Re: "Check Installation" fails

Post by cas » Apr 17, 2019 8:56 am

Upgrade your php to version 7.1.26 because that is required for mantis :mrgreen:

federico
Posts: 36
Joined: Mar 27, 2019 12:35 pm

Re: "Check Installation" fails

Post by federico » Apr 22, 2019 3:15 am

Sorry, and thank you very much.

It must be my english comprehension... Hard things of working in a foreign language.

cas
Posts: 668
Joined: Mar 11, 2006 11:08 am
Contact:

Re: "Check Installation" fails

Post by cas » Apr 22, 2019 5:16 am

Well the message can be cryptic for foreignors, hope all worked out ok now.

atrol
Site Admin
Posts: 7677
Joined: Mar 26, 2008 4:37 pm
Location: Germany

Re: "Check Installation" fails

Post by atrol » Apr 22, 2019 5:50 am

cas wrote:
Apr 17, 2019 8:56 am
Upgrade your php to version 7.1.26 because that is required for mantis :mrgreen:
Not true, the minimum required version is 5.5.0 https://github.com/mantisbt/mantisbt/bl ... nc.php#L38
cas wrote:
Apr 22, 2019 5:16 am
Well the message can be cryptic for foreignors
@cas, not only for foreigners, but also you :D

This is what is checked and should deliver TRUE

Code: Select all

Version of PHP installed is at least 5.5.0
this is the result, which means that 7.1.26 is installed on the server

Code: Select all

PHP version 7.1.26 is currently installed on this server.	FAIL
The strange thing is that version_compare does not deliver true, so the check fails.
https://github.com/mantisbt/mantisbt/bl ... nc.php#L43
Please use Search before posting and read the Manual

cas
Posts: 668
Joined: Mar 11, 2006 11:08 am
Contact:

Re: "Check Installation" fails

Post by cas » Apr 23, 2019 7:14 am

I stand corrected, i got confused by the fact that the comparison failed so I deducted, too quickly, that it was the other way around.
In addition i should have known, since i am ruunning php 7.0x :oops:

Post Reply