Page 1 of 1

data maintained but going for higher version interface

Posted: Jan 03, 2018 10:46 am
by SunnyMantis
Due to platform changes, we need to move all mantis data onto a higher version bug tracker system, still mantis, but way beyond the current version (1.1.7). I wonder whether it is possible to read existing mantis data (from 1.1.7) in a brand new mantis interface (i.e. 2.8.0) ? Please advise.

Re: data maintained but going for higher version interface

Posted: Jan 04, 2018 2:08 am
by atrol
You can export your 1.1.7 database and import it in a new database instance.
Unpack latest Mantis (2.1.10 at the moment) under your web server and follow the upgrade instructions from
https://www.mantisbt.org/docs/master/en ... ll.upgrade

Re: data maintained but going for higher version interface

Posted: Jan 09, 2018 9:37 am
by SunnyMantis
Thank you, any requirement for O.S ? the old data was on windows server 2003 mysql; I do run into trouble in the past when doing the same steps moving data onto macOS mysql , so wonder any restrictions ?
Meanwhile, I will grab another system to follow your instructions.

Re: data maintained but going for higher version interface

Posted: Jan 09, 2018 9:46 am
by atrol

Re: data maintained but going for higher version interface

Posted: Jan 09, 2018 5:05 pm
by SunnyMantis
Thank you for confirming that. You just help me make decision to give up. :-)
no way I can move mantis into another mantis after almost 10years, too old system, too old database.
I have tried a few of times, all failed.

Re: data maintained but going for higher version interface

Posted: Jan 09, 2018 5:14 pm
by Starbuck
I'm confused on what part of this you're giving up on.
Can't get v2.0 installed on your existing OS? Why not virtualize?
Can't get current mySQL in your existing OS? Why not virtualize?
Why not just host the whole thing in a cloud system for about $6/month or less?
Or is there some issue with specific data where there is a mismatch between your data or code and the current MantisBT?

Re: data maintained but going for higher version interface

Posted: Jan 09, 2018 5:17 pm
by atrol
SunnyMantis wrote:Thank you for confirming that.
I don't understand what you mean with it. What did I confirm?
SunnyMantis wrote:decision to give up.
Why give up? Does it mean that you don't have any system where you can run PHP >= 5.5 and MySQL >= 5.5.35?

Re: data maintained but going for higher version interface

Posted: Jan 10, 2018 10:51 am
by SunnyMantis
Thank you for the followup. Understand you don't understand as we are actually giving up mantis, transferring data to another system. The reason I want to make current mantis still 'alive' is to keep mantis data viewed in mantis way after the windows2003 platform gonegone. :-)

You just confirmed with me that I am NOT on the wrong track, so thank you for that.