Email Reporting Plugin not compatible with Mantisbt 2.4.1

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Developer, Contributor

testasy
Posts: 1
Joined: Jun 08, 2017 12:38 am

Email Reporting Plugin not compatible with Mantisbt 2.4.1

Post by testasy »

I'm new to Mantisbt.

I just made a fresh install of Mantisbt 2.4.1 and am trying to install Email Reporting 0.9.3.1, but in the Manage Plugins section it is showing that Plugin is deprecated.

Can anyone help with this? Or is there any other way to configure issue reporting via email in Mantisbt 2.4.1?

SL-Gundam
Posts: 605
Joined: Jul 06, 2011 9:17 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by SL-Gundam »

Install from here https://github.com/mantisbt-plugins/EmailReporting the 0.10.0-DEV version

amit.patel
Posts: 5
Joined: Jun 22, 2017 6:41 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by amit.patel »

Hi,

I have configured Email reporting plugin 0.10 (dev), but it not working.

I do get error as per below:
Location: Attempt login
[pear_error: message=", " code=0 mode=return level=notice prefix="" info=""]

amit.patel
Posts: 5
Joined: Jun 22, 2017 6:41 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by amit.patel »

I have install Matnisbt 2.4.1 and Email reporting 0.10.0-DEV but it is not working , I have other mantis Old versions on same server and that is working fine.

But for 2.4.1 email reporting not fetching mails.

I receive error in logs:

Location: Attempt login
[pear_error: message=", " code=0 mode=return level=notice prefix="" info=""]

SL-Gundam
Posts: 605
Joined: Jul 06, 2011 9:17 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by SL-Gundam »

What email server are you using?

Which version of MantisBT and EmailReporting are you running in the old version

amit.patel
Posts: 5
Joined: Jun 22, 2017 6:41 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by amit.patel »

Hello SL-Gundam,

Thanks for reply , We are using Zimbra mail server (IMAP) for all our mantis old and new .
Old Mantis : Mantis BT version : 1.2.17 and Email Reporting : Email Reporting 0.9.0-DEV which is working fine without any issues on same Mantis server.

I have configured Mailbox(IMAP-993) for new Mantis and Email reporting same as old mantis and reporting server. (another email user and domain).

Thanks

SL-Gundam
Posts: 605
Joined: Jul 06, 2011 9:17 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by SL-Gundam »

I believe the encryption part was reconfigured to be more logical.

Could you provide the full configuration for your mailbox in EmailReporting?

If you encryption is set to none. try one of the other values. STARTTLS is probably what was default before

amit.patel
Posts: 5
Joined: Jun 22, 2017 6:41 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by amit.patel »

Hello,

I have tried the STARTTLS but still not working.
Configuration:

Enabled [?] Yes
Description [?] someproject
Mailbox type [?] IMAP
Hostname [?] <Mail Server Hostname>
TCP port (optional) [?] 993
Connection encryption [?] STARTTLS
Verify SSL certificate [?] Yes
Username [?] <Username of the mailbox on the mail server>
Password [?] <Password of the mailbox>
Authentication method [?] USER

Basefolder (optional) [?]
Create project subfolder structure [?] No

Select a project [?] <Some Project>
Select a category [?] General

SL-Gundam
Posts: 605
Joined: Jul 06, 2011 9:17 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by SL-Gundam »

i Suggest the following

If using 993 (default SSL port) as the port number select SSL or TLS as the encryption
If using 143 as the port number try None or STARTTLS for the encryption

During testing turn off "Verify SSL certificate". After you've got everything working i suggest you enable this one again.

amit.patel
Posts: 5
Joined: Jun 22, 2017 6:41 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by amit.patel »

Many Thanks SL-Gundam,

That did work out :)
993 (default SSL port) as the port number with TLS as the encryption.

really appreciate your help.

Ancy
Posts: 46
Joined: Jun 30, 2017 6:10 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by Ancy »

Will the email plugin work on Mantis2.5.0 ?
Because we have upfdated from 1.1.2 to 2.5.0 now.can anyone please respond?

SL-Gundam
Posts: 605
Joined: Jul 06, 2011 9:17 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by SL-Gundam »

Update EmailReporting to 0.10.0-DEV and everything should work without issues

Ancy
Posts: 46
Joined: Jun 30, 2017 6:10 am

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by Ancy »

Thank you so much for responding.

GeminiDomino
Posts: 2
Joined: Aug 01, 2017 12:05 pm

Re: Email Reporting Plugin not compatible with Mantisbt 2.4.

Post by GeminiDomino »

Where's the download for 0.10.0-DEV? The link in the readme goes to the releases download list, but the newest one listed there is 0.9.3.1 and it's not showing me any branches other than "master" and "master-0.9.x"


Post Reply