Page 1 of 1

Error with 0.9.3 in MantisBT v1.2.20

Posted: Jan 20, 2017 12:04 pm
by franksanabria
Hí, I did use EmailReporting v0.9.3DEV with out any problem, but, when I use EmailReporting_v0.9.3 I have this error (attached)

php --version
PHP 5.4.16 (cli) (built: Nov 6 2016 00:29:02)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

MariaDB:
mysql Ver 15.1 Distrib 5.5.52-MariaDB, for Linux (x86_64) using readline 5.1

SO Versión:
CentOS Linux release 7.3.1611 (Core)

Re: Error with 0.9.3 in MantisBT v1.2.20

Posted: Jan 20, 2017 12:42 pm
by SL-Gundam
Try the following:

This file and line
https://github.com/mantisbt-plugins/Ema ... .php#L1534

Change

Code: Select all

. '( SELECT 1 FROM ' . db_get_table( 'bug' ) . ' B WHERE B.id = issue_id )';
to

Code: Select all

. '( SELECT 1 FROM ' . db_get_table( 'mantis_bug_table' ) . ' B WHERE B.id = issue_id )';
Please let me know whether or not this fixes the issue

This problem does not exist for MantisBT 1.3.x or 2.0.x so you might also consider upgrading your MantisBT installation

Re: Error with 0.9.3 in MantisBT v1.2.20

Posted: Jan 20, 2017 1:28 pm
by franksanabria
Yes is the solution, thank you for you answere

Re: Error with 0.9.3 in MantisBT v1.2.20

Posted: Jan 20, 2017 2:35 pm
by SL-Gundam