IMAP Login Successful, But No Messages Retrieved

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Contributor, Developer

Post Reply
Auseklis
Posts: 2
Joined: Dec 22, 2017 9:21 am
Location: Richmond, Virginia, USA

IMAP Login Successful, But No Messages Retrieved

Post by Auseklis » Dec 22, 2017 9:30 am

Hello all,

First, let me confirm that I have read the documentation and have tried searching this forum and Google for answers, but I have not found one.

So here's the issue....

I know that EmailReporting is successfully logging into the IMAP account I want to use because the folder structure on the mail server changes when I add new projects in MantisBT.

However... I sent a test message to the account, which I can see sitting in the Inbox, yet it never gets pulled into MantisBT.

Perhaps I am missing something simple, but would someone give me an idea where to look or point out whatever obvious thing I have missed? 8)

SL-Gundam
Posts: 500
Joined: Jul 06, 2011 9:17 am

Re: IMAP Login Successful, But No Messages Retrieved

Post by SL-Gundam » Dec 22, 2017 12:47 pm

Based on your description you have enabled the option "Create project subfolder structure"
In this situation EmailReporting will only process the subfolders created, not the INBOX folder.

Turn off this setting and EmailReporting will process the Basefolder

Auseklis
Posts: 2
Joined: Dec 22, 2017 9:21 am
Location: Richmond, Virginia, USA

Re: IMAP Login Successful, But No Messages Retrieved

Post by Auseklis » Dec 22, 2017 10:01 pm

Yes, thanks. I eventually realized that I needed to create mail filters on the mail filter side to place messages in the right folders to be imported. All works great now, thanks!

Post Reply