View Issue Details

IDProjectCategoryView StatusLast Update
0007753mantisbtotherpublic2018-01-30 06:55
Reporterdeboutv Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSRedhatOS Version9.0
Product Version1.1.0a2 
Summary0007753: Wiki rights
Description

To create/edit a page, user needs to have a global access level allowing creation/edition of wiki page.

By example, user having the following access level can not edit/create pages: global access level = VIEWER, project access_level = DEVELOPER (the project is private).

TagsNo tags attached.

Relationships

duplicate of 0008249 new DokuWiki user rights 

Activities

vboctor

vboctor

2007-03-13 00:05

manager   ~0014177

The current code attempt to determine the project id given the wiki namespace, then use the project-specific access level as the group to which the user belongs. The problem with that approach is that a user can probably go to a wiki page that they have access to then navigate to other pages belonging to other pages.

I think the groups should be associated as follows:

  • PROJECTA_DEVELOER
  • PROJECTB_VIEWER
  • PROJECTC_MANAGER

This way, the required Wiki access rights can be different per project in the Wiki, so inside the PROJECTA namespace, the required access can be PROJECTA_DEVELOPER and in PROJECTB namespace, the required access can be PROJECTB_DEVELOPER, etc.

deboutv

deboutv

2007-03-15 03:21

reporter   ~0014186

Hi Victor,

I have fixed this issue in my Wiki plugin http://deboutv.free.fr/mantis/plugin.php?plugin=Wiki

And I change the namesapce management because with some project name (french name by example), the project name in Mantis is different from the namespace of the dokuwiki (dokuwiki renames the name to remove special characters).

I have also added "Mantis:12:summary" that will be remplaced by the summary of the issue 12 (it works with other fields)

pluntke

pluntke

2008-01-24 15:29

reporter   ~0016801

this seems related to 0008249

dregad

dregad

2018-01-19 17:32

developer   ~0058567

Closing in favor of 0008249 which is actually the same problem, but has a better description of the problem and includes a (very old) patch provided by the community.

Issue History

Date Modified Username Field Change
2007-02-07 04:16 deboutv New Issue
2007-03-13 00:05 vboctor Note Added: 0014177
2007-03-13 00:05 vboctor Status new => confirmed
2007-03-15 03:21 deboutv Note Added: 0014186
2008-01-24 15:29 pluntke Note Added: 0016801
2018-01-19 17:32 dregad Assigned To => dregad
2018-01-19 17:32 dregad Status confirmed => resolved
2018-01-19 17:32 dregad Resolution open => duplicate
2018-01-19 17:32 dregad Note Added: 0058567
2018-01-19 17:32 dregad Relationship added duplicate of 0008249
2018-01-30 06:55 atrol Status resolved => closed