View Issue Details

IDProjectCategoryView StatusLast Update
0004850mantisbtbugtrackerpublic2008-08-12 09:35
Reporterschneiderj Assigned Tograngeway  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Product Version0.19.1 
Summary0004850: Application error #401 pdf-upload doesn't work
Description

upload of pdf-files doesn't work. i get the application error 0000401. the pdf-files are about 4 MB large. other documents work.

TagsNo tags attached.

Relationships

has duplicate 0004849 closedvboctor Application error 0000401 pdf-upload doesn't work 
child of 0004350 closeddhx FAQ 

Activities

thraxisp

thraxisp

2004-11-22 19:39

reporter   ~0008405

This sounds like an issue with mySQL setup. I assume that you are saving files to the DATABASE.

Is it all large files that fail? If so, you could look at the "max_allowed_packet" parameter in the my.cnf file in your installation.

leonel

leonel

2005-01-27 07:23

reporter   ~0009114

I just experienced a similar issue on my mantis installation. I had no "max_allowed_packet" configured on my.cnf. Setting it to 16M, according to instructions in the following page, solved the problem:

http://dev.mysql.com/doc/mysql/en/packet-too-large.html

jlatour

jlatour

2005-12-07 03:08

reporter   ~0011706

Are the docs and admin/check.php clear on this?

marcgeldon

marcgeldon

2006-08-12 13:45

reporter   ~0013254

I had the same problem. My "max_allowed_packet" was configured to 1 MB (/etc/my.cnf). I changed it to the same size as the maximum allowed upload size from PHP. Now it does work!

marcgeldon

marcgeldon

2006-08-12 13:46

reporter   ~0013255

Maybe it's possible to get the "max_allowed_packet" variable in any way (via a SELECT?) from the mySQL server. I nice idea would be to check this size with the maximum upload size from PHP. If the "max_allowed_packet" value is lower, warn the user/administrator.

chillax

chillax

2006-08-14 14:08

developer   ~0013271

SHOW VARIABLES LIKE 'max_allowed_packet';

grangeway

grangeway

2008-05-02 18:20

reporter   ~0017740

Thank you for taking the time to report a problem with mantis.

Since this problem report was originally made, a number of releases have occurred.
It appears that this issue has either been fixed, or may not be a relevant report for the current release.

Unfortunately you are not using the latest version and the problem might already be fixed. Please download the latest release from http://www.mantisbt.org/download.php

If you are able to reproduce this bug in the current release, or have some more information on how this feature could be improved in the current release. Please either change the mantis version on this bug report
to the version you tested and change the status back to "Open", or open a new issue report wit more information.

Again, thank you for your bug report and your continued support.
Paul

Issue History

Date Modified Username Field Change
2004-11-10 05:29 schneiderj New Issue
2004-11-10 05:32 vboctor Relationship added has duplicate 0004849
2004-11-22 19:39 thraxisp Note Added: 0008405
2004-11-22 19:39 thraxisp Status new => feedback
2005-01-27 07:23 leonel Note Added: 0009114
2005-12-07 03:08 jlatour Note Added: 0011706
2005-12-07 03:09 jlatour Relationship added child of 0004350
2006-08-12 13:45 marcgeldon Note Added: 0013254
2006-08-12 13:46 marcgeldon Note Added: 0013255
2006-08-14 14:08 chillax Note Added: 0013271
2008-05-02 18:20 grangeway Status feedback => resolved
2008-05-02 18:20 grangeway Resolution open => no change required
2008-05-02 18:20 grangeway Assigned To => grangeway
2008-05-02 18:20 grangeway Note Added: 0017740
2008-08-12 09:35 grangeway Status resolved => closed