View Issue Details

IDProjectCategoryView StatusLast Update
0004221mantisbtbugtrackerpublic2008-07-24 16:50
ReporterDGtlRiftAssigned Tograngeway 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version0.19.0a2 
Target VersionFixed in Version 
Summary0004221: Automatic Email Reminder of unresolved issues.
Description

There should be a reminder of unresolved issues older then some threshhold (perhaps user configurable) that emails the assigned user.

Additional Information

Try clicking on view bugs and reverse sorting by date. There are a number of issues on the bugs.mantisbt.org that are duplicates, already fixed, or apparently wont be fixed, but are still open and unresolved.

TagsNo tags attached.

Relationships

duplicate of 0006646 acknowledged Weekly nag email script 
related to 0005499 closedgrangeway Can Mantis send "Nag" Reminders to Developer/Manager when bug is old 
related to 0006465 closedgrangeway Feature request for daily mail report 
related to 0006528 closedgrangeway Whinning feature, similar to bugzilla 
related to 0005887 new How about a daily report send by email to managers and developers? 

Activities

anarcat

anarcat

2005-02-02 13:22

reporter   ~0009174

I guess the real issue here is to figure out two things:

1) how to have a "cron" (scheduled tasks) infrastructure within mantis. One can rely on external cron jobs or have an internal task manager. There are a few solutions for this:

2) have a way to list all those bugs, with the email contacts and make up a mail to actually send, recording all this in each bug's history.

3) anything else?

At any rate, the general approach should be to build a script that does the actual necessary work and let it be called as http://bugs.mantis.org/cron.php.

A.

SneakyWho_am_i

SneakyWho_am_i

2008-05-18 17:52

reporter   ~0017868

Some scripts that I've used, which can do fake and/or real cronning (cronning?) require for you to (un)check a box to toggle the fake cron.
I like that, but I would like it more if it could try to add the cron entry automatically first. I see the process a little like this:

  • ask how often the cron job should execute
  • generate the cron command-line thing
  • try to execute it (backtick operator? check that we're actually on unix first?)
    then either
    1: cron attempt successful, congratulate user, fetch beer
    OR
    2: cron job fails, send user to error page which:
    2a: Shows the command-line string "just in case" they can do it by hand after all
    2b: the error message from the system, if any
    2c: the error message from php, if any
    2d: remembers the post data - if they're on windows it might be a handy creature comfort to be able to copy what they already decided straight from their browser to task-scheduler or whatever windows has.
    2e: offers the option to do a "fake cron" with that data
    2f: (maybe) offers to use some kind of weird hosted web cron thing

using a web based cron thing instead of one installed on the system?? That idea seems freaky. Would that be slow? Does it send in an email when the job iterates? Scary thought.

NB for 2f, on that page all you might be doing is taking options for setting something in the database. Your webservices script or whatever may only have to receive data and flip a switch.
2e could be even easier because it might only mean sticking something in the database
And of course ideally you just want "1:"

I might provide the code from my RSS posting plugin (not my work, but I have a copy) if it is GPL and I remember to do it.

Issue History

Date Modified Username Field Change
2004-07-29 15:40 DGtlRift New Issue
2005-02-02 13:22 anarcat Note Added: 0009174
2006-03-09 13:05 ryandesign Relationship added related to 0005499
2006-03-09 13:05 ryandesign Relationship added related to 0006465
2006-03-09 13:05 ryandesign Relationship added related to 0006528
2006-03-09 13:05 ryandesign Relationship added related to 0006646
2006-03-09 13:05 ryandesign Relationship added related to 0005887
2008-05-18 17:52 SneakyWho_am_i Note Added: 0017868
2008-07-15 16:56 grangeway Relationship replaced duplicate of 0006646
2008-07-15 16:56 grangeway Status @0@ => resolved
2008-07-15 16:56 grangeway Resolution @0@ => duplicate
2008-07-15 16:56 grangeway Assigned To => grangeway
2008-07-24 16:50 vboctor Status @0@ => closed