View Issue Details

IDProjectCategoryView StatusLast Update
0003728mantisbtotherpublic2004-05-17 10:26
Reporterastax Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18.2 
Summary0003728: CSV export shows " instead of real quotes in bug title
Description

When clicking "CSV export" link on bugs list page, resulting file contains " instead of real quotes in "summary" column.

TagsNo tags attached.

Activities

vboctor

vboctor

2004-04-07 05:42

manager   ~0005350

I re-implemented csv export in CVS code, and I think I fixed this problem. Check it out and let me know if you find any issues.

astax

astax

2004-04-07 05:57

reporter   ~0005351

Sorry, I'm not familiar with mantis CVS tree and don't know how to get latest snapshot. Can anybody else test this?

2004-04-07 06:30

 

csv.zip (3,162 bytes)
vboctor

vboctor

2004-04-07 06:31

manager   ~0005352

Backup your csv_export.php, then copy the two files in the zip file to your Mantis directory. They should work with 0.18.2 (I think).

astax

astax

2004-04-08 03:11

reporter   ~0005354

Yes, this fixed the problem with quotes, thank you.

But now when I'm opening resulting CSV file in Excel (Office 2000 russian, bild 9.0.2812) it says "SYLK: invalid file format". I had already seen this problem earlier. It's caused by capitals in header line:
ID,Project,Reporter,Assigned To,Priority,Severity.....

If I manually replace "ID" with "id" or even "Id", file is open without any problems. I believe Excel tries to identify file format and for some reason thinks it's not CSV, but SYLK.

astax

astax

2004-04-08 06:30

reporter   ~0005355

This problem is described in Microsoft Knowledge Base
http://support.microsoft.com/default.aspx?scid=kb;en-us;323626&Product=xlw

As you can see it applies to all versions of MS Office, so I think it's reasonable to make a workaround for this. Probably just slightly changing name of the first column - Bug ID, Id, ID or whatever.

vboctor

vboctor

2004-04-08 07:18

manager   ~0005356

Fixed in CVS. Will be available in the next release.

Thanks astax for chasing up the SYLK problem.

Related Changesets

MantisBT: master 39631f16

2004-04-08 11:05:12

vboctor

Details Diff
Fix 0003728: CSV export shows " instead of real quotes in bug title.

M csv_export.php
- The main bug was fixed in the re-implementation of the csv export done earlier.
- This commit fixes the error "SYLK: invalid file format" error that used to be prompted by Excel.

git-svn-id: http://mantisbt.svn.sourceforge.net/svnroot/mantisbt/trunk@2482 <a class="text" href="/?p=mantisbt.git;a=object;h=f5dc347c">f5dc347c</a>-c33d-0410-90a0-b07cc1902cb9
Affected Issues
0003728
mod - csv_export.php Diff File
mod - doc/ChangeLog Diff File

Issue History

Date Modified Username Field Change
2004-04-07 05:35 astax New Issue
2004-04-07 05:42 vboctor Note Added: 0005350
2004-04-07 05:42 vboctor Assigned To => vboctor
2004-04-07 05:42 vboctor Status new => assigned
2004-04-07 05:57 astax Note Added: 0005351
2004-04-07 06:30 vboctor File Added: csv.zip
2004-04-07 06:31 vboctor Note Added: 0005352
2004-04-08 03:11 astax Note Added: 0005354
2004-04-08 06:30 astax Note Added: 0005355
2004-04-08 07:18 vboctor Status assigned => resolved
2004-04-08 07:18 vboctor Resolution open => fixed
2004-04-08 07:18 vboctor Note Added: 0005356
2004-05-17 10:26 vboctor Status resolved => closed
2008-10-21 13:12 Changeset attached master-1.1.x 84cbeade =>
2008-11-11 08:41 vboctor Changeset attached master 39631f16 =>
2008-11-11 08:54 vboctor Changeset attached master 39631f16 =>