View Issue Details

IDProjectCategoryView StatusLast Update
0031081mantisbtbugtrackerpublic2022-11-29 14:36
Reportermgmantis Assigned Toatrol  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.25.5 
Summary0031081: GUI are messed up
Description

we were trying to upgrade from 2.11.1 to 2.25.5 with PHP7, we found the the GUI are messed up. I uploaded an attachment for your reference.

Steps To Reproduce

1). go to the mantis website: <root url>/mantisbt-2.25.5/my_view_page.php
2). right away you see those unaligned fields
-All Projects dop down list: cannot pull up
-under user (top right corner), the drop down list has "RSS" and "Logout", which cannot be pulled up

3). when clicking any issues, got "
APPLICATION ERROR 0000401
Database query failed. Error received from database was #1054: Unknown column 'bugnote_id' in 'field list' for the query: SELECT id, title, diskfile, filename, filesize, file_type, date_added, user_id, bugnote_id
FROM mantis_bug_file_table
WHERE bug_id=?
ORDER BY date_added.

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
"

TagsNo tags attached.
Attached Files
mantis_2.25.5_bug_myview.GIF (181,348 bytes)   
mantis_2.25.5_bug_myview.GIF (181,348 bytes)   
mantis_2.25.5_bug_user.GIF (4,853 bytes)   
mantis_2.25.5_bug_user.GIF (4,853 bytes)   
mantis_2.25.5_bug_query.GIF (75,287 bytes)   
mantis_2.25.5_bug_query.GIF (75,287 bytes)   

Activities

mgmantis

mgmantis

2022-10-06 09:44

reporter   ~0067050

tried with firefox, edge, and chrome, it is not browser related.

dregad

dregad

2022-10-06 11:53

developer   ~0067051

Not sure how you performed the upgrade, but something's definitely gone wrong there.

Please read https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.install.upgrade

mgmantis

mgmantis

2022-10-14 14:13

reporter   ~0067070

basically i followed instructions from here: https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.install.upgrade

herew are the steps:
1). downloaded, unzipped and untared into mantisbt-2.25.5
2). changed group to the right one
3). changed mod for the directory to 755
4). copied over 4 existing config files:
-custom_strings_inc.php
-custom_constants_inc.php
-custom_functions_inc.php
-config_inc.php
5). copied over existing plugins from working version (2.11.1)
-CrbsEmailNotify
-CrbsOwnerHiddenField
-jQuery
-Taskodrome

Note we currently use PHP7.

atrol

atrol

2022-10-17 13:36

developer   ~0067077

I guess you did not run step 5 of the mentioned topic in Admin Guide

Execute the upgrade script. From your web browser, access
https://yoursite/mantisbt-NEW/admin/install.php

Clean also your browser cache.

mgmantis

mgmantis

2022-10-17 14:02

reporter   ~0067078

my concern is that running the install.php will upgrade the database in production...

mantis_admin_install_php.GIF (44,425 bytes)   
mantis_admin_install_php.GIF (44,425 bytes)   
atrol

atrol

2022-10-17 14:08

developer   ~0067079

my concern is that running the install.php will upgrade the database in production..

That is exactly what this script does.
You can't run 2.25.5 using an outdated 2.11.1 database.

mgmantis

mgmantis

2022-10-26 13:42

reporter   ~0067105

i did a dry run of the admin install script, and got the following:

Database Creation Suppressed, SQL Queries follow
Please note that executing the generated script below
may not result in a fully functional database
, particularlyin upgrade scenarios. This is due to the fact that some upgrade steps require the execution of PHP code; these
Upgrade Functions
are defi ned in
install_helper_functions_api.php
and cannot be translated to SQLstatements. Use at your own risk.
-- MantisBT 2.25.5 Database creation script
-- 2022-10-26T18:30:45+02:00
-- Schema step 210
ALTER TABLE mantis_bug_fi le_table ADD bugnote_id INTEGER UNSIGNED DEFAULT 0;
-- Schema step 211
ALTER TABLE mantis_email_table MODIFY COLUMN email VARCHAR(191) NOT NULL DEFAULT '';
-- Set database version
UPDATE mantis_confi g_table SET value = 211 WHERE confi g_id = 'database_version' AND project_id = 0 AND user_id = 0;

Your database is not ready yet !
Please create it, then install the tables and data using the above script beforeproceeding.
Updating Confi guration File (confi g/confi g_inc.php) GOOD
Attempting to connect to database as user GOOD
checking ability to SELECT records GOOD
checking ability to INSERT records GOOD
checking ability to UPDATE records GOOD
checking ability to DELETE records GOOD

i checked, all these tables exist, why it said "Your database is not ready yet !" whaty are missing here?

atrol

atrol

2022-10-26 14:48

developer   ~0067106

Seems you have enabled the check-box "Primt SQL Queries instead of Writing to the Database", so the database was not changed.
You could run the script without this option enabled, or you could run the printed queries manually, but as mentiond in the message this may not result in a fully functional database ...

atrol

atrol

2022-11-16 14:07

developer   ~0067148

mgmantis,

You did not provide new feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide additional information if your issue is not fixed.

mgmantis

mgmantis

2022-11-29 14:36

reporter   ~0067173

Thanks for your help! Really appreciated.