View Issue Details

IDProjectCategoryView StatusLast Update
0028830mantisbtcode cleanuppublic2021-06-20 09:16
Reporterdregad Assigned Todregad  
PrioritylowSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Target Version2.26.0Fixed in Version2.26.0 
Summary0028830: Remove PHP < 5.4 compatibility code from user_get_all_accessible_projects()
Description

Code was added in issue 0016187 to avoid issues following a change in behavior of array_combine() function in PHP 5.4.

The test is no longer necessary since we now require PHP 7.0 or later.

TagsNo tags attached.

Relationships

related to 0025956 resolveddregad Increase minimum PHP requirement to 7.0 
related to 0016187 closeddregad Application error on fresh install 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master dfdcd29d

2021-06-20 09:02:11

dregad

Details Diff
Remove code needed only for PHP < 5.4

This test was added in issue 0016187 and is no longer necessary since
we require PHP 7.0 or later.

Fixes 0028830
Affected Issues
0016187, 0028830
mod - core/user_api.php Diff File