View Issue Details

IDProjectCategoryView StatusLast Update
0028531mantisbtbugtrackerpublic2021-06-05 07:39
Reporterronemjay Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2.25.0 
Summary0028531: List markers do not appear in project dropdown menu
Description

The list markers for projects and subprojects do not appear, all that appears is spacing.
Please see screenshot attached.
I've tried with all browsers and none works.
Kind regards.

TagsNo tags attached.

Activities

ronemjay

ronemjay

2021-05-12 04:00

reporter  

list-markers-not-showing.png (128,713 bytes)   
list-markers-not-showing.png (128,713 bytes)   
dregad

dregad

2021-05-12 10:02

developer   ~0065497

I'm not sure what you mean by list markers, and it is also not quite clear from your description what exactly is not working.

ronemjay

ronemjay

2021-05-13 12:07

reporter   ~0065511

Sorry, let me clarify.
On the project dropdown menu, you can only identify projects and their subprojects by their respective levels of indentation. Please see image attached.

Using Chrome's inspect element feature I can see marker elements aligned to the left of each project menu item but they are not visible and way past the left side of the menu.

For reference, I have also attached the list arrow markers that are included in the projects page that show project hierarchies.
Is there a way to replicate these into the projects dropdown menu?

Kind regards.

dregad

dregad

2021-05-15 05:03

developer   ~0065514

OK I get it now.

The markers off the menu's div box are hidden due to use of the overflow-x attribute on the menu item's parent list (scrollable-menu class). Changing this at CSS level is beyond my limited skills, and honestly I wouldn't recommend messing with it as it is part of the bootstrap template we're using.

You can still achieve what you want fairly easily, by customizing the indentation in layout_navbar_subproject_option_list() function, which is currently set to 4 non-breakable spaces:

diff --git a/core/layout_api.php b/core/layout_api.php
index f2f20f9e0..1a749c87f 100644
--- a/core/layout_api.php
+++ b/core/layout_api.php
@@ -640,7 +640,7 @@
    array_push( $p_parents, $p_parent_id );
    $t_user_id = auth_get_current_user_id();
    $t_project_ids = user_get_accessible_subprojects( $t_user_id, $p_parent_id );
-   $t_indent = str_repeat( ' ', 4 );
+   $t_indent = '» ';

    foreach( $t_project_ids as $t_id ) {
        if( $p_trace ) {

This is not something we would implement in Core, so I'm closing the issue as won't fix.

atrol

atrol

2021-05-15 05:26

developer   ~0065516

@dregad at least we provided nearly the same answer ;-)
https://mantisbt.org/forums/viewtopic.php?p=71813#p71813

Not sure you are aware we use raquo on manage_proj_page.php

ronemjay

ronemjay

2021-05-24 02:03

reporter   ~0065549

Thanks dregad for the information.
For this issue, Atrol provided a solution which worked perfectly for my case.
Kind regards.