View Issue Details

IDProjectCategoryView StatusLast Update
0028076mantisbtplug-inspublic2021-05-13 06:58
ReporterLukeWCS Assigned Todregad  
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.25.0 
Target Version2.25.1Fixed in Version2.25.1 
Summary0028076: Bundled plugins 2.25.0: incorrect Mantis requirement
Description

The minimum version was defined as "2.1.0". In version 2.25.0 the function print_icon () was used in the file config.php, which is only available from Mantis 2.25.0. I noticed this when I was looking at the dependencies for my first Mantis plugin.

TagsNo tags attached.

Relationships

related to 0027828 closeddregad Standardize the way fontawesome icons are printed 

Activities

dregad

dregad

2021-03-17 04:39

developer   ~0065250

Good catch, thank you. Will fix.

dregad

dregad

2021-03-17 04:48

developer   ~0065251

Same problem for the other bundled plugins (XmlImportExport and MantisGraph)

Related Changesets

MantisBT: master 6a95b078

2021-03-17 04:42:06

dregad

Details Diff
Set bundled plugins Core requirement to 2.25.0

Following introduction of print_icon() API in issue 0027828, the bundled
plugins' MantisCore requirement must be increased as they are relying on
the new function.

Fixes 0028076
Affected Issues
0027828, 0028076
mod - plugins/MantisCoreFormatting/MantisCoreFormatting.php Diff File
mod - plugins/MantisGraph/MantisGraph.php Diff File
mod - plugins/XmlImportExport/XmlImportExport.php Diff File