View Issue Details

IDProjectCategoryView StatusLast Update
0027958mantisbtuipublic2021-03-07 18:28
Reporterdregad Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027958: Inconsistent form input labels' font size when HTML `label` element is used
Description

Form inputs should be associated with a label, for compatibility with screen readers.

This transformation has been applied to a few pages already, but this is causing the display to change as the default font size for labels is slightly larger (14px) than the default font used when displaying regular text (13px).

TagsNo tags attached.

Relationships

related to 0027258 closeddregad Code cleanup around User/Global Profiles 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master 3081131d

2021-02-06 19:09:31

dregad

Details Diff
CSS: fix font size for labels in table cells

HTML inputs should be associated with a label, for screen readers.

A lot of our forms are in tables, with one column containing the label
and another the corresponding input.

Adding the <label> element in this scenario causes the display to
change the font size, due to the default defined in ace.css as 14px,
but in table cells it is 13px (derived from body).

This overrides the font-size for th/td labels, so the labels visual
aspect stays the same after adding <labels> elements.

Follow-up on d27ea37de79604f9e6cbbd908383085f4a5f679a.

Fixes 0027958
Affected Issues
0027958
mod - css/ace-mantis.css Diff File