View Issue Details

IDProjectCategoryView StatusLast Update
0027854Plugin - EmailReportingGeneralpublic2021-01-15 13:37
Reportersintaq Assigned ToSL-Gundam  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0027854: EmailReporting doesnt create note on the existing ticket
Description

Attached is my current setup for EmailReporting

It works fine previously but now the company implemented a tagging to the email's subject to indicate an email coming from outside of the the company's domain, it seems that EmailReporting couldnt find the existing ticket and end up create new one. I know this is not Email Reporting's direct issue but is the any chance for enhancement? Sample flow as below. Hope i got my situation clear. Many thanks

Steps To Reproduce

Initial email's subject from Mantis
[Project 1: Test Project 0006648] ; Test ticket

When someone from outside of the company reply to this, the subject will be
[EXTERNAL]; [Project 1: Test Project 0006648] ; Test ticket

TagsNo tags attached.

Activities

sintaq

sintaq

2021-01-08 03:59

reporter  

image.png (72,439 bytes)   
image.png (72,439 bytes)   
SL-Gundam

SL-Gundam

2021-01-08 08:38

manager   ~0064962

Both the example subject lines seem to be working fine in in my testing.

It might be something hidden that we can't see.
Is it possible you activate debug mode and provide a raw_msg of the email so we can have a look at that?

sintaq

sintaq

2021-01-11 09:59

reporter   ~0064967

@SL-Gundam

I'm not able to reproduce the behavior using Gmail(external) with my company's domain. These were simulation I've tried

1) Create tix in Mantis. Receive notification(assigned notification) from mantis with mail's subject [Project Test 0008258]: [Request ID ##RE-12345## ] MZ MZO TEST EXTERNAL EMAIL 1
2) From email in step 1, Outlook reply to Gmail. Note successfully created in Mantis 8258
3) From email in step 2, Gmail reply to Outlook. Email from Gmail received with mail's subject [EXTERNAL]: Re: [Project Test 0008258]: [Request ID ##RE-12345## ] MZ MZO TEST EXTERNAL EMAIL 1 and note successfully created in Mantis 8258
4) From email in step 3, Outlook reply to Gmail. Note successfully created in Mantis 8258
5) From email in step 4,Gmail reply to Outlook. Email from Gmail received with mail's subject [EXTERNAL]: Re: [EXTERNAL]: Re: [Project Test 0008258]: [Request ID ##RE-12345## ] MZ MZO TEST EXTERNAL EMAIL 1 and note successfully created in Mantis 8258
6) From email in step 5, Outlook reply to Gmail. Note successfully created in Mantis 8258
7) From email in step 6, Gmail reply to Outlook. Email from Gmail received with mail's subject [EXTERNAL]: Re: [EXTERNAL]: Re: [EXTERNAL]: Re: [Project Test 0008258]: [Request ID ##RE-59862## ] MZ MZO TEST EXTERNAL EMAIL 1 and note successfully created

At moment i'm turning on debug to monitor the behavior and hopefully able to catch something

SL-Gundam

SL-Gundam

2021-01-12 09:53

manager   ~0064969

Since you cannot reproduce it i suspect it was just an out-of-order processing issue. EmailReporting processed the reply before the initial new ticket was processed. Easily checked by seeing which ticket ID is higher.

sintaq

sintaq

2021-01-13 01:37

reporter   ~0064972

@SL-Gundam

Perhaps it just an out of order processing issue. Will monitor and update if the issue persists

BTW, how does EmailReporting indicate from email received whether to create new ticket or to add new note to existing ticket? Based on the email's subject? Thanks

SL-Gundam

SL-Gundam

2021-01-13 11:46

manager   ~0064975

By default it uses 2 methods with different options. You can disable/change these as needed
http://www.mantisbt.org/wiki/doku.php/mantisbt:plugins:emailreporting#mail_subject_id_regex
http://www.mantisbt.org/wiki/doku.php/mantisbt:plugins:emailreporting#mail_use_message_id

sintaq

sintaq

2021-01-14 09:40

reporter   ~0064976

@SL-Gundam

Symptom detected today. Attached is the raw message.

Ticket 0007654 is actually existed in my system. However, EmailReporting creating new ticket instead.

raw_msg.txt (6,262 bytes)   
Received: from BMEXCHMB03.company.domain.com.mai (172.27.10.688) by
 BMEXCHMB02.company.domain.com.mai (172.27.10.822) with Microsoft SMTP Server
 (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256) id 15.1.1913.5
 via Mailbox Transport; Thu, 14 Jan 2021 13:17:20 +0800
Received: from BMEXCHMB02.company.domain.com.mai (172.27.10.822) by
 BMEXCHMB03.company.domain.com.mai (172.27.10.688) with Microsoft SMTP Server
 (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256) id
 15.1.1913.5; Thu, 14 Jan 2021 13:17:20 +0800
Received: from BMEXCHMB02.company.domain.com.mai ([fe80::5c6:680a:af83:e89f]) by
 BMEXCHMB02.company.domain.com.mai ([fe80::69be:68c1:76dc:4097%5]) with mapi id
 15.01.1913.010; Thu, 14 Jan 2021 13:17:20 +0800
From: Mohammad Zairi Othman <mohammad.zairi@domain.com.mai>
To: Yuzailenda Yusof <yuzailenda@domain.com.mai>
CC: ticket.mantis <ticket.mantis@domain.com.mai>, Nor'Asyikin Abd Rashid
	<asyikin@domain.com.mai>, Anuari Syukri Sulaiman <anuari@domain.com.mai>,
	IT Core companying <ITCorecompanying@domain.com.mai>, Safoorah Mohamad
	<safoorah@domain.com.mai>, Project Management Department
	<pmd@domain.com.mai>
Subject: RE: [CR58491: Human Capital Management System  0007654]: 2.5 CR
 proposed solution sign off acceptance
Thread-Topic: [CR58491: Human Capital Management System  0007654]: 2.5 CR
 proposed solution sign off acceptance
Thread-Index: AQHW6jQ9uA+kJr7V6ECeY984eAv1ZKomlEFA
Date: Thu, 14 Jan 2021 13:17:20 +0800
Message-ID: <6b3dfe56a97c4e539cd6a0d5565266aa@domain.com.mai>
References: <ymXSNjpyLK7m3KzIZ8tvzJrAptvtRH0h0IF0hOUHo@172.27.10.104>
In-Reply-To: <ymXSNjpyLK7m3KzIZ8tvzJrAptvtRH0h0IF0hOUHo@172.27.10.104>
Accept-Language: en-US
Content-Language: en-US
X-MS-Exchange-Organization-AuthAs: Internal
X-MS-Exchange-Organization-AuthMechanism: 04
X-MS-Exchange-Organization-AuthSource: BMEXCHMB02.company.domain.com.mai
X-MS-Has-Attach:
X-MS-Exchange-Organization-Network-Message-Id:
	a1e3fd6d-51b1-4db2-84a2-08d8b84baadd
X-MS-Exchange-Organization-SCL: -1
X-MS-TNEF-Correlator:
X-MS-Exchange-Organization-RecordReviewCfmType: 0
Content-Type: multipart/alternative;
	boundary="_000_6b3dfe56a97c4e539cd6a0d5565266aadomaincommai_"
MIME-Version: 1.0

--_000_6b3dfe56a97c4e539cd6a0d5565266aadomaincommai_
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64

RGVhciBQbi5MZW5kYQ0KTWFudGlzIDc2NTQgcmVmZXJyZWQgZm9yIHlvdXIgZnVydGhlciBhY3Rp
b25zLg0KDQpMZXQgbWUga25vdyBpZiB5b3UgbmVlZCBmdXJ0aGVyIGNsYXJpZmljYXRpb25zLiBU
aGFua3MNCg0KUmVnYXJkcywNClphaXJpDQoNCi0tLS0tT3JpZ2luYWwgTWVzc2FnZS0tLS0tDQpG
cm9tOiB0aWNrZXQubWFudGlzQG11YW1hbGF0LmNvbS5teSBbbWFpbHRvOnRpY2tldC5tYW50aXNA
bXVhbWFsYXQuY29tLm15XSANClNlbnQ6IFRodXJzZGF5LCAxNCBKYW51YXJ5LCAyMDIxIDE6MTUg
UE0NClRvOiBNb2hhbW1hZCBaYWlyaSBPdGhtYW4NClN1YmplY3Q6IFtDUjU4NDkxOiBIdW1hbiBD
YXBpdGFsIE1hbmFnZW1lbnQgU3lzdGVtIDAwMDc2NTRdOiAyLjUgQ1IgcHJvcG9zZWQgc29sdXRp
b24gc2lnbiBvZmYgYWNjZXB0YW5jZQ0KDQpBIE5PVEUgaGFzIGJlZW4gYWRkZWQgdG8gdGhpcyBp
c3N1ZS4NCg0KLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tLS0tLS0tLS0tLS0tLSANCiAoMDAyMjkzMCkgQk0tSVRDb3JlLU1vaGFtbWFkIFph
aXJpIChhZG1pbmlzdHJhdG9yKSAtIDE0LTAxLTIwMjEgMTM6MTQNCiBodHRwczovLzE3Mi4yNy4x
MC4xMDQvdmlldy5waHA/aWQ9NzY1NCNjMjI5MzAgDQotLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tIA0KUFMgaW4gaHR0
cHM6Ly8xNzIuMjcuMTAuMTA0L3ZpZXcucGhwP2lkPTc2NTEjYzIyODU1IHJlZmVycmVkLg0KDQpQ
bGVhc2UgcHJvdmlkZSBQUyBhY2NlcHRhbmNlIHNpZ24gb2ZmIGZvciB1cyB0byBwcm9jZWVkIHdp
dGggZGV2ZWxvcG1lbnQgYW5kDQphZHZpc2UgeW91IG9uIHRoZSBVQVQgcmVhZGluZXNzIGRlbGl2
ZXJ5LiBUaGFua3MNCi0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0t
LS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0NCg0K

--_000_6b3dfe56a97c4e539cd6a0d5565266aadomaincommai_
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: base64
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--_000_6b3dfe56a97c4e539cd6a0d5565266aadomaincommai_--
raw_msg.txt (6,262 bytes)   
SL-Gundam

SL-Gundam

2021-01-14 18:02

manager   ~0064982

It's a completely normal subject line so nothing wrong there.
I would need the raw_msg of the original ticket and any subsequent notes to test the raw_msg.

Was the original ticket resolved or close by any chance?
https://www.mantisbt.org/wiki/doku.php/mantisbt:plugins:emailreporting#readonly_threshold_for_issues

sintaq

sintaq

2021-01-15 12:06

reporter   ~0064989

@SL-Gundam

Original issue still in open status. However, I believed i found the culprit caused by my side, due to internal customization done when processing the email's subject. My apology

After reading your advise in 0027854:0064975 , it shed some light. Many thanks
You may resolve/close this ticket.