View Issue Details

IDProjectCategoryView StatusLast Update
0027815mantisbtupgradepublic2021-01-16 09:27
Reporterednar Assigned Todregad  
PriorityurgentSeveritycrashReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version2.24.4 
Summary0027815: Unable to update Issue
Description

Hello,

We have just upgrade to 2.24.4, and we receive a server error when trying to update some issues.

If we downgrade to our previous release of 2.24.1 we do not receive error

Steps To Reproduce

Try update issue

TagsNo tags attached.

Relationships

has duplicate 0027824 resolvedatrol Server 500 Error 
has duplicate 0027841 resolvedatrol Updating Issues Error 

Activities

dregad

dregad

2020-12-30 12:09

developer   ~0064876

Can you be a little bit more specific as to the error you're getting, and the steps leading to it ? As it is, I don't see how we could possibly help.

ednar

ednar

2020-12-30 12:20

reporter   ~0064877

We have existing mantis of 2.24.1

We download the latest update.

When a user went to update a bug, they receive an 500 error from the server

If we replace the files from the latest update with a new download of 2.24.1, it works fine.

Presumably there are changes in patch when issues are updated. For now, we roll back to 2.24.1 as it holiday and end of work day soon. Maybe you fix issue.

ednar

ednar

2020-12-30 12:21

reporter   ~0064878

PHP is version 7.2.34 if need you help

atrol

atrol

2020-12-30 13:15

developer   ~0064883

a server error when trying to update some issues

Is there some more information in webserver / PHP logs?

Do you have any 3rd party plugins installed?

ednar

ednar

2020-12-30 13:53

reporter   ~0064884

That strange - could not access bug - clicking on the link to view atrol comment did not open and took client back to main page. After logout and log back in can view again. It seems like new version has issues - maybe are resolve January?

no 3rd party plugins installed. Web server log show bug update return 500 error

dregad

dregad

2020-12-31 08:43

developer   ~0064893

@ednar your problem is not reproducible.

Please provide actual, detailed errors from your PHP log, otherwise we can't help you.

atrol

atrol

2021-01-06 07:12

developer   ~0064937

Last edited: 2021-01-06 07:13

@ednar do you have set $g_allow_no_category = ON?

If yes, does applying the fix for 0027826 also fix your issue?
https://github.com/mantisbt/mantisbt/commit/074b3f5d8b75689eed98107c94bb580c46d1086d

atrol

atrol

2021-01-16 05:02

developer   ~0064990

ednar,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

dregad

dregad

2021-01-16 09:27

developer   ~0064995

Unable to reproduce is a more appropriate resolution