View Issue Details

IDProjectCategoryView StatusLast Update
0026971mantisbtwebpagepublic2020-06-13 06:14
Reporterkanni1303 Assigned Toatrol  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2.24.1 
Summary0026971: Login Page Broken
Description

No info other than logo in the login page

The error log shown as below
[20-May-2020 13:11:38 UTC] PHP Fatal error: require_once(): Failed opening required 'admin/schema.php' (include_path='.:/opt/alt/php72/usr/share/pear') in /home/asaimani/public_html/mantis/login_page.php on line 182
[20-May-2020 13:12:59 UTC] PHP Fatal error: require_once(): Failed opening required 'admin/schema.php' (include_path='.:/opt/alt/php72/usr/share/pear') in /home/asaimani/public_html/mantis/login_page.php on line 182

In Admin folder
[20-May-2020 13:11:05 UTC] PHP Fatal error: require_once(): Failed opening required 'schema.php' (include_path='.:/opt/alt/php72/usr/share/pear') in /home/asaimani/public_html/mantis/admin/index.php on line 27

Steps To Reproduce

open login_page.php

Additional Information

Home itself broken unable to proceed with anymore

TagsNo tags attached.

Relationships

related to 0026974 resolvedatrol Required PHP json extension not documented and checked 

Activities

dregad

dregad

2020-05-20 09:35

developer   ~0064009

This is most likely caused by your system's configuration or the way you installed Mantis.

kanni1303

kanni1303

2020-05-20 10:08

reporter   ~0064010

what is the resolution? I am not able to do anything.

kanni1303

kanni1303

2020-05-20 10:27

reporter   ~0064011

Even after adding the schema.php manually getting this error

[20-May-2020 14:23:30 UTC] Call to undefined function json_decode()
/home/asaimani/public_html/mantis/core.php: 319: - - - - collapse_cache_token()
/home/asaimani/public_html/mantis/login_cookie_test.php: 33: - - - - require_once( <string>'/home/asaimani/public_html/mantis/core.php' )

[20-May-2020 14:23:30 UTC] Call to undefined function json_decode()
/home/asaimani/public_html/mantis/core.php: 319: - - - - collapse_cache_token()
/home/asaimani/public_html/mantis/javascript_config.php: 30: - - - - require_once( <string>'/home/asaimani/public_html/mantis/core.php' )

[20-May-2020 14:23:35 UTC] Call to undefined function json_decode()
/home/asaimani/public_html/mantis/core.php: 319: - - - - collapse_cache_token()
/home/asaimani/public_html/mantis/my_view_page.php: 41: - - - - require_once( <string>'/home/asaimani/public_html/mantis/core.php' )

[20-May-2020 14:23:36 UTC] Call to undefined function json_decode()
/home/asaimani/public_html/mantis/core.php: 319: - - - - collapse_cache_token()
/home/asaimani/public_html/mantis/javascript_config.php: 30: - - - - require_once( <string>'/home/asaimani/public_html/mantis/core.php' )

[20-May-2020 14:23:52 UTC] Call to undefined function json_decode()
/home/asaimani/public_html/mantis/core.php: 319: - - - - collapse_cache_token()
/home/asaimani/public_html/mantis/view_all_bug_page.php: 39: - - - - require_once( <string>'/home/asaimani/public_html/mantis/core.php' )

[20-May-2020 14:23:53 UTC] Call to undefined function json_decode()
/home/asaimani/public_html/mantis/core.php: 319: - - - - collapse_cache_token()
/home/asaimani/public_html/mantis/javascript_config.php: 30: - - - - require_once( <string>'/home/asaimani/public_html/mantis/core.php' )

atrol

atrol

2020-05-21 06:34

developer   ~0064012

Last edited: 2020-05-21 06:35

View 2 revisions

@kanni1303 does it work after enabling / installing PHP json extension ?

kanni1303

kanni1303

2020-05-21 07:30

reporter   ~0064013

Thank you, after enabling JSON it is working. But unable to open any bug.

showing following error whenever opening any bug.

image.png (31,889 bytes)   
image.png (31,889 bytes)   
atrol

atrol

2020-05-21 07:49

developer   ~0064015

Last edited: 2020-05-21 07:49

View 2 revisions

Do you use an old Mantis database that contains old bug reports ?

If yes, did you upgrade by following the steps described in Admin Guide ? https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.install.upgrade
Especially, did you run the upgrade script ? http://yoursite/mantisbt-NEW/admin/install.php

atrol

atrol

2020-06-02 16:58

developer   ~0064056

kanni1303,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2020-05-20 09:21 kanni1303 New Issue
2020-05-20 09:35 dregad Assigned To => dregad
2020-05-20 09:35 dregad Status new => resolved
2020-05-20 09:35 dregad Resolution open => unable to reproduce
2020-05-20 09:35 dregad Note Added: 0064009
2020-05-20 09:35 dregad Priority immediate => normal
2020-05-20 10:08 kanni1303 Note Added: 0064010
2020-05-20 10:27 kanni1303 Note Added: 0064011
2020-05-21 06:34 atrol Assigned To dregad =>
2020-05-21 06:34 atrol Status resolved => feedback
2020-05-21 06:34 atrol Resolution unable to reproduce => reopened
2020-05-21 06:34 atrol Note Added: 0064012
2020-05-21 06:35 atrol Note Edited: 0064012 View Revisions
2020-05-21 07:30 kanni1303 Note Added: 0064013
2020-05-21 07:30 kanni1303 File Added: image.png
2020-05-21 07:30 kanni1303 Status feedback => new
2020-05-21 07:42 atrol Relationship added related to 0026974
2020-05-21 07:49 atrol Status new => feedback
2020-05-21 07:49 atrol Note Added: 0064015
2020-05-21 07:49 atrol Note Edited: 0064015 View Revisions
2020-06-02 16:58 atrol Assigned To => atrol
2020-06-02 16:58 atrol Status feedback => resolved
2020-06-02 16:58 atrol Resolution reopened => no change required
2020-06-02 16:58 atrol Note Added: 0064056
2020-06-13 06:14 atrol Status resolved => closed