View Issue Details

IDProjectCategoryView StatusLast Update
0026957mantisbtmigrationpublic2020-06-02 16:56
Reporteramphetamine Assigned Todregad  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.24.0 
Summary0026957: MySQL migration, APPLICATION ERROR #401
Description

windows localhost running MantisBT is very well
try to migrate to dreamhost webhost

database name: bugtracker3

  1. upload all mantis folder to webhost
  2. import backup sql file to webhost
  3. admin/check
  4. login and get APPLICATION ERROR 0000401

Database query failed. Error received from database was 0001146: Table 'bugtracker3.mantis_plugin_Announce_message_table' doesn't exist for the query: SELECT m., c., c.id AS context_id FROM mantis_plugin_Announce_message_table AS m
JOIN mantis_plugin_Announce_context_table AS c ON c.message_id=m.id
LEFT JOIN mantis_plugin_Announce_dismissed_table as d ON d.context_id=c.id and d.user_id=?
WHERE (d.timestamp IS NULL or d.timestamp < m.timestamp)
AND c.location = ? AND c.project_id = ?
AND c.access <= ? ORDER BY m.timestamp DESC.

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Additional Information

try to fresh install Mantisbt on dreamhost, everything is okay.
then delete all the MySQL, and upload the backup sql file, then got the same error 401

TagsNo tags attached.

Activities

amphetamine

amphetamine

2020-05-13 02:23

reporter  

image.png (83,583 bytes)   
image.png (83,583 bytes)   
dregad

dregad

2020-05-13 03:12

developer   ~0063973

The fact that Mantis works fine with a fresh install on your webhost, implies that there is something wrong with your DB migration procedure. Are you sure that you are importing to the right database instance, and with the same schema name bugtracker3 ?

This is not a bug or feature request for MantisBT (you are asking for help on how to migrate / configure the system on a new server). I am therefore resolving this issue as "no change required".

Please use the forums, the mantisbt-help mailing list or IRC to get support on customizing and using MantisBT (see http://www.mantisbt.org/support.php)

amphetamine

amphetamine

2020-05-14 02:35

reporter   ~0063981

Last edited: 2020-05-14 02:36

View 2 revisions

https://mantisbt.org/forums/viewtopic.php?p=70014#p70014

after change the database table's name, then work

mantis_plugin_Announce_context_table
mantis_plugin_Announce_dismissed_table
mantis_plugin_Announce_message_table

dregad

dregad

2020-05-14 10:05

developer   ~0063983

So this is a problem with MySQL table identifier case. By default, table aliases are case-sensitive on Unix, but not so on Windows or macOS

See https://dev.mysql.com/doc/refman/8.0/en/identifier-case-sensitivity.html

Issue History

Date Modified Username Field Change
2020-05-13 02:23 amphetamine New Issue
2020-05-13 02:23 amphetamine File Added: image.png
2020-05-13 03:12 dregad Assigned To => dregad
2020-05-13 03:12 dregad Status new => resolved
2020-05-13 03:12 dregad Resolution open => no change required
2020-05-13 03:12 dregad Note Added: 0063973
2020-05-14 02:35 amphetamine Note Added: 0063981
2020-05-14 02:36 amphetamine Note Edited: 0063981 View Revisions
2020-05-14 10:05 dregad Note Added: 0063983
2020-06-02 16:56 atrol Status resolved => closed