View Issue Details

IDProjectCategoryView StatusLast Update
0026956mantisbtadministrationpublic2020-06-02 16:56
Reporternoelworking Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.24.1 
Summary0026956: Admin checks detect database UTF-8 collation required
Description

mantis/admin/check/index.php [Check]

[Database]
Table mantis_api_token_table is using UTF-8 collation
Table mantis_api_token_table is using collation where UTF-8 collation is required.

TagsNo tags attached.

Activities

noelworking

noelworking

2020-05-13 01:30

reporter   ~0063972

Last edited: 2020-05-13 01:55

View 2 revisions

Is there no problem if deleting mantis_api_token_table...?
Or is it okay to just use it?

how can i fix it?

dregad

dregad

2020-05-13 03:21

developer   ~0063974

Is there no problem if deleting mantis_api_token_table...?

You should never delete a table, or more generally speaking, perform direct SQL manipulation against the Mantis database, this is not supported.

That being said, if the token table is empty then you should be able to alter its definition to set utf8 collation

Or is it okay to just use it?

Why do you think we added a check to warn you about it ?

how can i fix it?

https://lmgtfy.com/?q=mysql+alter+table+collation

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2020-05-12 21:09 noelworking New Issue
2020-05-13 01:30 noelworking Note Added: 0063972
2020-05-13 01:55 noelworking Note Edited: 0063972 View Revisions
2020-05-13 03:21 dregad Assigned To => dregad
2020-05-13 03:21 dregad Status new => resolved
2020-05-13 03:21 dregad Resolution open => no change required
2020-05-13 03:21 dregad Note Added: 0063974
2020-06-02 16:56 atrol Status resolved => closed