View Issue Details

IDProjectCategoryView StatusLast Update
0026604mantisbtupgradepublic2020-02-09 07:05
Reporterklax Assigned Todregad  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Product Version2.23.0 
Summary0026604: Problem with upgrade
Description

Hello, I have a problem with the mantis upgrade from version 2.2.0 to the current 2.23.0 or according to information from the forum, to version 2.24.0 . I did all the steps in accordance with the upgrade procedure, but when I run the install.php script I have a problem connecting to the database (psql). Authorized user has full rights to the database. I am asking for help what can cause this problem.

-Attempting to connect to database as admin BAD
Does administrative user have access to the database? ( Database connection failed )
-Checking Database Server Version POSSIBLE PROBLEM
Unable to determine 'pgsql' version. ().

The other fields are verified correctly and I receive the information GOOD.

Best regards

TagsNo tags attached.

Activities

dregad

dregad

2020-01-17 05:03

developer   ~0063456

This simply means that Mantis was not able to connect to your database using the provided information. The installer gives you the option to provide a separate, admin account but it can be the same as your regular account (in some installations, an account with lower privileges is used for everyday operations). Make sure you're using the correct credentials and DB connection parameters.

I'm afraid there's not much more we can do to help... This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

lampacz

lampacz

2020-01-23 08:05

reporter   ~0063499

It's not good implemented. In install.php is called connect do db without db
$t_result = @$g_db->Connect( $f_hostname, $f_admin_username, $f_admin_password);

without db, postgres connects to default database called template1 (at least connect privilege)

Mostly you have defined one user which have rights to own db.

so for upgrade (when db exists) is needed add db name (db already exists), eg.:
$t_result = @$g_db->Connect( $f_hostname, $f_admin_username, $f_admin_password, $f_database_name);

Issue History

Date Modified Username Field Change
2020-01-17 04:11 klax New Issue
2020-01-17 05:03 dregad Assigned To => dregad
2020-01-17 05:03 dregad Status new => resolved
2020-01-17 05:03 dregad Resolution open => no change required
2020-01-17 05:03 dregad Note Added: 0063456
2020-01-23 08:05 lampacz Note Added: 0063499
2020-02-09 07:05 atrol Status resolved => closed