View Issue Details

IDProjectCategoryView StatusLast Update
0026572mantisbtcode cleanuppublic2020-03-15 15:23
Reporterrogueresearch Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.24.0Fixed in Version2.24.0 
Summary0026572: Remove $g_log_destination 'firebug' option, as the project is dead since 2017
Description

The Admin Guide:

https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/

describes an option:

$g_log_destination - 'firebug' - make use of Firefox Firebug Add-on. If user is not running firefox, this options falls back to the default php error log settings.

According to its website (https://getfirebug.com/), that project is dead since 2017. So it could be a simplification to mantis to just remove support for that.

TagsNo tags attached.

Activities

dregad

dregad

2020-01-08 03:12

developer   ~0063387

Good point, I'll take care of it.

dregad

dregad

2020-01-08 03:23

developer   ~0063388

PR https://github.com/mantisbt/mantisbt/pull/1608

Related Changesets

MantisBT: master 3b1de423

2020-01-08 03:16:13

dregad

Details Diff
Remove 'firebug' as logging destination

Firebug development stopped in 2017 with the launch of Firefox 57 [1].

Fixes 0026572

[1]: https://getfirebug.com/
Affected Issues
0026572
mod - admin/check/check_config_inc.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/logging_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/logging.xml Diff File

Issue History

Date Modified Username Field Change
2020-01-07 16:35 rogueresearch New Issue
2020-01-08 03:00 dregad Assigned To => dregad
2020-01-08 03:00 dregad Status new => assigned
2020-01-08 03:11 dregad Reproducibility have not tried => N/A
2020-01-08 03:11 dregad Target Version => 2.24.0
2020-01-08 03:11 dregad Summary Remove $g_log_destination 'firebug' option, as the 'firebug' project is dead since 2017 => Remove $g_log_destination 'firebug' option, as the project is dead since 2017
2020-01-08 03:12 dregad Description Updated View Revisions
2020-01-08 03:12 dregad Note Added: 0063387
2020-01-08 03:23 dregad Note Added: 0063388
2020-01-09 10:58 dregad Changeset attached => MantisBT master 3b1de423
2020-01-09 10:58 dregad Status assigned => resolved
2020-01-09 10:58 dregad Resolution open => fixed
2020-01-09 10:58 dregad Fixed in Version => 2.24.0
2020-03-15 15:23 vboctor Status resolved => closed