View Issue Details

IDProjectCategoryView StatusLast Update
0026543mantisbtemailpublic2020-01-12 10:27
Reporterbmaniece Assigned Toatrol  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Summary0026543: Issue update takes longer time if email notification is enabled
Description

It has been observed that if email notifications are enabled, then the associated action takes a longer time to complete. We felt, including our customers that it's a hard job. Can it be optimized?

TagsNo tags attached.

Activities

atrol

atrol

2019-12-31 10:35

developer   ~0063349

You could try using a cron job to send emails, see option $g_email_send_using_cronjob in Admin Guide https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.email
This is typically not needed if everything else is setup well.

bmaniece,

This is not a bug or feature request for MantisBT (you are asking for help on how to deal with performance issues on your system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

If you think the problem is caused by a bug in Mantis, feel free to reopen the issue, but provide detailed, step-by-step instructions to reproduce the issue; the additional information listed below may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
  • Are there any entries in mantis_email_table ?
  • What does takes longer time exactly mean ?
  • How many recipients get an email if an issue is updated ?

Issue History

Date Modified Username Field Change
2019-12-31 08:26 bmaniece New Issue
2019-12-31 10:35 atrol Assigned To => atrol
2019-12-31 10:35 atrol Status new => resolved
2019-12-31 10:35 atrol Resolution open => no change required
2019-12-31 10:35 atrol Note Added: 0063349
2020-01-12 10:27 atrol Status resolved => closed