View Issue Details

IDProjectCategoryView StatusLast Update
0026518mantisbtcustom fieldspublic2020-01-28 02:04
Reporterpedro.henrique Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2.21.0 
Summary0026518: When trying to create a custom field an error occurs: null value in column "require_report" violates not-null constraint
Description

When trying to create a custom field an error occurs.

APPLICATION ERROR 0000401

Query to database failed. Error received from database was #-1:ERROR: null value in column "require_report" violates not-null constraint
DETAIL: Failing row contains (46, testepedro, 0, , , , 0, 0, 0, 0, null, null, null, null, null, null, null, null, null)." for consultation: "INSERT INTO mantis_custom_field_table ( name, possible_values )
VALUES ( $1,$2)"

Apparently mantis is only requesting the field name, other information is not being requested.

I use version 2.21.0, has this been fixed in the latest version?

TagsNo tags attached.

Activities

pedro.henrique

pedro.henrique

2019-12-27 14:35

reporter  

atrol

atrol

2019-12-31 10:38

developer   ~0063350

You created the issue in project Plugin - LinkedCustomFields.
Is this intended? I don't see at the moment that the issue is related to this 3rd party plugin,.

pedro.henrique

pedro.henrique

2020-01-02 08:31

reporter   ~0063358

You can move to the right project, just want to understand why this problem.

atrol

atrol

2020-01-02 10:35

developer   ~0063361

Last edited: 2020-01-02 11:12

View 2 revisions

pedro.henrique,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.23.0 at the moment).

If you check the table, e.g. via DESC mantis_custom_field_table you should see that the column require_report comes with a default valus of 0, thus a not-null constraint can't be violated.

The following additional information may be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
atrol

atrol

2020-01-12 10:26

developer   ~0063427

pedro.henrique,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2019-12-27 14:35 pedro.henrique New Issue
2019-12-27 14:35 pedro.henrique File Added: Erro campo personalizado mantis 2.jpg
2019-12-27 14:35 pedro.henrique File Added: Erro campo personalizado mantis 1.jpg
2019-12-31 10:38 atrol Status new => feedback
2019-12-31 10:38 atrol Note Added: 0063350
2020-01-02 08:31 pedro.henrique Note Added: 0063358
2020-01-02 08:31 pedro.henrique Status feedback => new
2020-01-02 10:27 atrol Project Plugin - LinkedCustomFields => mantisbt
2020-01-02 10:28 atrol Category General => custom fields
2020-01-02 10:28 atrol Product Version => 2.21.0
2020-01-02 10:28 atrol Description Updated View Revisions
2020-01-02 10:35 atrol Status new => feedback
2020-01-02 10:35 atrol Note Added: 0063361
2020-01-02 11:12 atrol Note Edited: 0063361 View Revisions
2020-01-12 10:26 atrol Assigned To => atrol
2020-01-12 10:26 atrol Status feedback => resolved
2020-01-12 10:26 atrol Resolution open => no change required
2020-01-12 10:26 atrol Note Added: 0063427
2020-01-28 02:04 atrol Status resolved => closed