View Issue Details

IDProjectCategoryView StatusLast Update
0026482mantisbtuipublic2020-01-12 10:07
Reporterrogueresearch Assigned Toatrol  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.23.0 
Target Version2.23.1Fixed in Version2.23.1 
Summary0026482: 'View Issue' page fails to populate some fields (ex 'ID') for some projects (but not others)
Description

We have 2.21.1 on our production server and are testing 2.23.0 on a test server.

We noticed a difference viewing some issues between 2.21.1 and 2.23.0. See attached image.

In 2.21.1 some fields didn't even get a heading. 2.23.0 seems to have added the heading (good!), but the value is still missing. In the screenshot, I would expect to see ID as "7142".

(We never noticed this in 2.21.1, probably just thought it was strange spacing/formatting, but the addition of the headers in 2.23.0 makes it move obvious this has been broken for a while.)

Additionally, the 'summary' field doesn't have the issue number prepended in 2.23.0 but does in 2.21.1. See attached image again.

It seems to happen for all issues in a particular project, but for no issues in other projects. Not sure what the relevant difference between projects is. The project where it occurs has many custom fields so it could be related to that.

TagsNo tags attached.

Relationships

related to 0025902 closedvboctor Implement IssueViewPageCommand to separate logic from rendering of issue view page 

Activities

rogueresearch

rogueresearch

2019-12-18 13:17

reporter  

MantisMissingFields.png (265,357 bytes)   
MantisMissingFields.png (265,357 bytes)   
atrol

atrol

2019-12-18 14:29

developer   ~0063314

In 2.21.1 some fields didn't even get a heading. 2.23.0 seems to have added the heading (good!),

This is / was not the stanadard, so I assume you have installed some custom functions and / or plugins on your our production server that have not been activated on your test server.

rogueresearch

rogueresearch

2019-12-18 16:07

reporter   ~0063315

The only plugins we have are the default ones, plus: Source, SourceSVN, and SourceGitlab (which is installed but not used yet). Prod server uses 2.2 and test server was upgraded to 2.3.

Not sure what you mean by "custom functions", but I don't believe we have any. We certainly didn't change any code (well only <https://github.com/mantisbt-plugins/source-integration/pull/261>)

The project in question does use many custom fields, all created in Mantis' own web UI.

atrol

atrol

2019-12-18 16:46

developer   ~0063316

Not sure what you mean by "custom functions"

Check if file config/custom_functions_inc.php exists on the production server.
That's where such functions are defined.

rogueresearch

rogueresearch

2019-12-18 17:49

reporter   ~0063317

No such file, only: .htaccess, Web.config, config_inc.php, config_inc.php.sample

atrol

atrol

2019-12-19 03:24

developer   ~0063320

It's better to start with the existing problem you have in 2.21.1, as this might be the root cause for the issue you get in 2.23.0.
There is no display of the labels and values for ID, Project and View Status.

I am not able to reproduce this behavior and none of our users entered a similar problem until now.
Are you able to provide step by step instructions starting from a fresh 2.21.1 installation to reproduce the issue?

The following additional information may be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Do you get any errors or warnings when running admin/check/index.php ?
  • Do you see any errors or warnings in browser console ?
  • Do you see any errors or warnings in your web server / database / PHP logs ?
atrol

atrol

2020-01-01 14:20

developer   ~0063352

rogueresearch,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

rogueresearch

rogueresearch

2020-01-01 19:35

reporter   ~0063355

The feedback will be coming. We use mantis at work, and we've been on xmas vacation recently... Back to work Jan 6, should have time that week to investigate more.

rogueresearch

rogueresearch

2020-01-07 13:56

reporter   ~0063376

Happy new year!

So we found how to trigger this.

Basically, several of our projects have customizations in Manage > Manage Configurations > Configuration Report.

For example, we configured "bug_view_page_fields" to:

array (
1 => 'project',
2 => 'category_id',
3 => 'summary',
4 => 'description',
5 => 'attachments',
6 => 'handler',
)

(see attached.)

If I delete that custom configuration entirely then the 2.23 view page again shows the "ID" field (and a whole bunch of other stuff).

So, I'd say 2.21.1 has correct behaviour and 2.23 is buggy:

a) it shouldn't show "ID" and other field headings that were removed in customization.
b) even if "ID" was removed in customization, it should nevertheless still use the ID in the "Summary" field.

bug_view_page_fields.png (43,058 bytes)   
bug_view_page_fields.png (43,058 bytes)   
atrol

atrol

2020-01-07 15:48

developer   ~0063377

Thanks @rogueresearch I am now able to reproduce the issue.

rogueresearch

rogueresearch

2020-01-07 16:38

reporter   ~0063379

Great!

BTW: those arrays in my last screenshot, do they have to have integer keys like that? If so, should they start at 0 or 1? I've noticed our customizations are inconsistent in that regard. Thanks.

atrol

atrol

2020-01-07 17:08

developer   ~0063381

Last edited: 2020-01-07 17:09

View 2 revisions

do they have to have integer keys like that?

No, they keys are added automatically when entering the arrays

atrol

atrol

2020-01-07 17:09

developer   ~0063382

PR https://github.com/mantisbt/mantisbt/pull/1607

rogueresearch

rogueresearch

2020-01-07 17:38

reporter   ~0063383

Cool, thanks for the speedy fix!

I don't know PHP, but from the look of the diff, the issue is merely cosmetic, correct? I'm trying to decide if this should prevent me from updating to 2.23.

Lastly, can PHP 5.4 syntax be used for those arrays? i.e. could I change:

array (
1 => 'project',
2 => 'category_id',
)

to just:

['project', 'category_id']
atrol

atrol

2020-01-07 18:02

developer   ~0063384

I'm trying to decide if this should prevent me from updating to 2.23.

I am not sure if I understand what you mean with this.
To summarize:

  • You are running 2.21.1 where the issue does not exist
  • The issue exists in 2.23.0
  • The issue will be fixed in 2.23.1, 2.24.0 and later versions (whenever these versions will be released)

When upgrading to 2.23.0, be aware that there is at least one more regression in 2.23.0 where you might be affected 0026470

Lastly, can PHP 5.4 syntax be used for those arrays?

No, but you can use this syntax to enter the configuration (as told before, keys are added automatically)

array ('project','category_id','summary','description', 'attachments','handler',)
rogueresearch

rogueresearch

2020-01-07 18:21

reporter   ~0063385

I am not sure if I understand what you mean with this.

Sorry for the confusion. I'm just wanting to be sure there isn't, for example, a database migration bug here. i.e. if I update from 2.21.1 to 2.23.0, yes, I'll have blank looking fields, but it's just a cosmetic issue. When I later upgrade to 2.23.1 or later, all my data is safe, and the cosmetic bug will also be fixed.

If this bug is indeed cosmetic only, I'll probably upgrade to 2.23.0 anyway.

Related Changesets

MantisBT: master-2.23 f5292645

2020-01-07 16:58:18

atrol

Details Diff
Fix field display on "View Issue" page

Fixes 0026482
Affected Issues
0026482
mod - bug_view_inc.php Diff File

Issue History

Date Modified Username Field Change
2019-12-18 13:17 rogueresearch New Issue
2019-12-18 13:17 rogueresearch File Added: MantisMissingFields.png
2019-12-18 14:29 atrol Status new => feedback
2019-12-18 14:29 atrol Note Added: 0063314
2019-12-18 16:07 rogueresearch Note Added: 0063315
2019-12-18 16:07 rogueresearch Status feedback => new
2019-12-18 16:46 atrol Status new => feedback
2019-12-18 16:46 atrol Note Added: 0063316
2019-12-18 17:49 rogueresearch Note Added: 0063317
2019-12-18 17:49 rogueresearch Status feedback => new
2019-12-19 03:24 atrol Status new => feedback
2019-12-19 03:24 atrol Note Added: 0063320
2020-01-01 14:20 atrol Assigned To => atrol
2020-01-01 14:20 atrol Status feedback => resolved
2020-01-01 14:20 atrol Resolution open => no change required
2020-01-01 14:20 atrol Note Added: 0063352
2020-01-01 19:35 rogueresearch Status resolved => feedback
2020-01-01 19:35 rogueresearch Resolution no change required => reopened
2020-01-01 19:35 rogueresearch Note Added: 0063355
2020-01-07 13:56 rogueresearch Note Added: 0063376
2020-01-07 13:56 rogueresearch File Added: bug_view_page_fields.png
2020-01-07 13:56 rogueresearch Status feedback => assigned
2020-01-07 15:46 atrol Relationship added related to 0025902
2020-01-07 15:47 atrol Resolution reopened => open
2020-01-07 15:48 atrol Note Added: 0063377
2020-01-07 16:38 rogueresearch Note Added: 0063379
2020-01-07 17:05 atrol Target Version => 2.23.1
2020-01-07 17:08 atrol Note Added: 0063381
2020-01-07 17:09 atrol Note Added: 0063382
2020-01-07 17:09 atrol Note Edited: 0063381 View Revisions
2020-01-07 17:38 rogueresearch Note Added: 0063383
2020-01-07 18:02 atrol Note Added: 0063384
2020-01-07 18:21 rogueresearch Note Added: 0063385
2020-01-12 10:07 atrol Changeset attached => MantisBT master-2.23 f5292645
2020-01-12 10:07 atrol Status assigned => resolved
2020-01-12 10:07 atrol Resolution open => fixed
2020-01-12 10:07 atrol Fixed in Version => 2.23.1